iPhone 3G iPhone 3G S data internet not working

Discussion in 'iPhone' started by Dbajj, Jun 27, 2009.

  1. Dbajj

    Dbajj New Member

    Joined:
    Oct 20, 2007
    Messages:
    100
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    So this morning I just got my brand new iPhone 3GS 16 gig and mostly everything has been smooth, synced all my apps and music and activated in store perfectly.

    Except now the problem is neither 3g or Edge are working properly.

    The actual icon and bars will show up just fine in the top left corner along with the carrier (Rogers) and everything looks like it should work. However when I actually go to any websites or use any internet based apps the loading icon will appear next to the 3g icon and sit there forever or until I close the app with no connection being established on any app.

    I have tried using it in various different places and calling as well as SMS are working fine and are speedy, just anything to do with the 3g or Edge connection will not function at all.

    If I enable Wifi the phone will pick it up, connect and everything will work fine.

    I have tried resetting Network Settings, then ALL settings and then finally a full restore however none of these have come up with any results.

    Just wondering if anyone has any suggestions before I just take the thing into Rogers and get a replacement.
  2. Spartigus

    Spartigus New Member

    Joined:
    Mar 2, 2008
    Messages:
    595
    Likes Received:
    2
    Device:
    iPhone 3GS (Black)
    Maybe they are still activating the data part. When i brought my iphone 3G S, they said wait till the next day before using data so it gets activated properly.
  3. Esviel

    Esviel New Member

    Joined:
    May 13, 2008
    Messages:
    8
    Likes Received:
    0
    I have an iPhone 3G (its not the new 3G S) and I'm having the exact same problem. I've had it for several months, it has worked fine in the past, but now all of a sudden my 3G internet access is acting all screwy. I can't rely on it, sometimes it works, sometimes it doesn't. Any ideas why?
  4. izook

    izook New Member

    Joined:
    Jul 8, 2009
    Messages:
    1
    Likes Received:
    0
    I'm having the same problem. it should be noted that my 3G S was working perfectly on 3G last night when I got it. I only noticed it stop working after I synced it and did a restore of all my apps and data from my 2G iphone ... I will try to put my sim back in the 2g and see if it's working which should cancel any involvement from the Network Operator. At which point if the proper plist or db containing the Network Data config are not identified then I will have no choice but to restore it to factory settings and not restore from back (which is extremely lame).
    ------------------double post merged------------------
    well didn't need to go to all that trouble ... this fixed it for me

    1. Tap Settings
    2. Tap General
    3. Tap Reset
    4. Tap Reset Network Settings
  5. mrdatax

    mrdatax Guest

    Thank you so much. I was looking for this solution EVERYWHERE!
    It just worked perfectly for my 3g

Share This Page