iPhone 3G iPhone 3G earpiece not working.

Discussion in 'iPhone' started by Awesomecolton, Oct 18, 2010.

  1. Awesomecolton

    Awesomecolton New Member

    Joined:
    Oct 18, 2010
    Messages:
    4
    Likes Received:
    0
    I recently did a repair on my 3G to fix the mute toggle. I put everything back together correctly(or so I thought.) and now my earpiece won't work. What number connector is this? Is there anything that could have went wrong?
  2. moshonas

    moshonas Member

    Joined:
    Feb 15, 2009
    Messages:
    345
    Likes Received:
    0
    Device:
    iPhone 5 (White)
    look at the schematics again. make sure your connections didnt cross over. (get a new phone if all fails)
  3. Awesomecolton

    Awesomecolton New Member

    Joined:
    Oct 18, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks for the reply. I did some research and found that the earpiece is the number 3 cable. I reopened the device, reconnected the cable, and still it does not work. I might have messed up the cable somehow...
  4. asymmetric

    asymmetric Banned

    Joined:
    Oct 20, 2010
    Messages:
    52
    Likes Received:
    0
    Well the earphones are always having problems. You should get the skullcandy ones.
  5. Awesomecolton

    Awesomecolton New Member

    Joined:
    Oct 18, 2010
    Messages:
    4
    Likes Received:
    0
    It's nothing to do with the earphones. My earphones work just fine. Its the earpiece, the part you press against your ear when you're in a call.

    I did some more research to find that i could have blown my proximity sensor screwing up the earpiece. If this is the case, then i can just replace the sensor.

Share This Page