iPhone 3G iphone 3g carrier (null) (null) help

Discussion in 'iPhone' started by dle24, Feb 20, 2009.

  1. dle24

    dle24 New Member

    Joined:
    Feb 10, 2008
    Messages:
    163
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Ok I am 2.2 and just jailbroke and unlocked it but when i put in my tmobile sim, there's no bars and the tmobile doesn't come up. I went to general and on carrier it says (null) (null). I'm pretty sure this is the problem, how can I make it work with my sim. Thanks.
    Never mind I figured it out.
  2. dette

    dette New Member

    Joined:
    Dec 5, 2008
    Messages:
    671
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Go to Cydia and search yellowsn0w and use that
  3. m2marsx

    m2marsx New Member

    Joined:
    Jan 27, 2009
    Messages:
    33
    Likes Received:
    0
    i had the same problem but i didn't see if it said null null like the ts said. tmobile wont come up and i have no bars. anyone know whats wrong? i have yellowsn0w downloaded.
  4. dette

    dette New Member

    Joined:
    Dec 5, 2008
    Messages:
    671
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Run Yellowsn0w with your T-Mobile SIM in the iPhone I believe thats what you do and you should be good

    Please Register or Log in to view images

    the iPhone will not automatically work with the T-Mobile SIM



    You also must have a baseband of 2.28 and NOT 2.30 so if you updated to 2.2.1 WITHOUT preserving the baseband yellowsn0w will not work
  5. m2marsx

    m2marsx New Member

    Joined:
    Jan 27, 2009
    Messages:
    33
    Likes Received:
    0
    what did you do to make it work? im having the same problem. i have yellowsn0w downloaded. im on 2.2 jailbroken firmware with 2.28.00 baseband and it says null null next to my carrier. i have no bars and the "T-mobile" isnt showing up?
    ------------------double post merged------------------
    never mind i got it now lol. i feel stupid now.

    Please Register or Log in to view images


    if anyone else is having trouble with this, make sure you install the actual yellowsn0w software after you install the source for it.
    after that reboot and i heard you have to wait 60 seconds before you install the sim but i didn't need to do that.
    then just toggle airplane mode on then off to search networks and it should come up.
  6. dette

    dette New Member

    Joined:
    Dec 5, 2008
    Messages:
    671
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Glad you got it figured out

    Please Register or Log in to view images

Share This Page