iPhone 3G iPhone 3G Blackra1n problem

Discussion in 'iPhone' started by SlipMat, Mar 3, 2010.

  1. SlipMat

    SlipMat New Member

    Joined:
    Mar 3, 2010
    Messages:
    1
    Likes Received:
    0
    Hi all

    I installed blackra1n on a friends iPhone 3G 3.1.2 and couldnt work out why I couldnt see Cydia/Rock/Sn0w under the installers... so I uninstalled Blackra1n to try again. I then realised that it was because I hadnt connected to WiFi... but now when I install blackra1n it brings up the install pic on the iPhone but doesnt reboot it just drops out to the normal iPhone screen and I dont get a Blackra1n icon. I know this is the problem because I just did another freinds and it works OK...

    So is there a way to do a factory restore? I dont want to do a restore using iTunes as I think this will upgrade to 3.1.3 and mean I cant jailbreak it at the moment. If I am wrong and a restore this way will be OK, please do let me know.

    Alternatively can I download a vanilla 3.1.2 firmware and reload it on the phone to start again?

    Or (easiest perhaps)... how can i reinstall Blackra1n to get the icon back??

    Any help grateful appreciated

    SM
  2. Sparkyx

    Sparkyx Member

    Joined:
    Aug 30, 2008
    Messages:
    225
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    You can try running blackra1n from another computer, try running blackra1n from Recovery Mode, or if you want to restore to 3.1.2, you must use the 3.1.2 firmware for your device, and hold SHIFT and click on RESTORE in iTunes. That will allow you to browse for the corresponding ipsw file.

Share This Page