iOS4 Problems

Discussion in 'iPod touch' started by metsfan913, Jun 21, 2010.

  1. metsfan913

    metsfan913 New Member

    Feb 16, 2009
    Likes Received:
    2G iPod touch
    Today I decided to update to iOS4. I backed up my iPod touch 2nd generation, and clicked update. It ended up not updating, but completely restoring the iPod. I had no problem with this, until the restore from backup ended up only restoring my music, photos,videos, and one application. I lost most of my application data after updating, and after trying a restore from a different backup, nothing changed. Does anyone have any idea as to how I would go about recovering this? (I'm using Windows Vista, if that helps.)

    Anyway, after I updated, I tried to jailbreak using redsn0w, figuring that I could attempt to get the backup later. I got up to the point where the iPod said, "Downloading jailbreak data" and then redsn0w crashed. I tried it a second time, this time without any other programs running, and it happened again. I am using the iOS4 GM, and I don't know what happened. Any help here?

    Thanks in advance!

Share This Page