iOS 4.0 iOS 4 Wi-Fi Connectivity Problems

Discussion in 'iOS Jailbreak & Cydia' started by neivin93, Aug 14, 2010.

  1. neivin93

    neivin93 New Member

    Joined:
    Jul 4, 2009
    Messages:
    61
    Likes Received:
    0
    Device:
    3G iPod touch
    Hey Everyone !
    I recently updated and jailbroke to iOS 4 and now my wi-fi connectivity is messed up.
    Earlier firmwares used to auto-connect me to my wi-fi as soon as I woke it up and unlocked.

    Now my Wi-fi just randomly disconnects when I open any app like Echofon or Facebook or YouTube.
    It only reconnects if I renew the lease from settings. But still when I open an app it disconnects again.

    This gets solved only temporarily if I reboot my iPod.

    My Wi-Fi was connected half a second ago ....

    Please Register or Log in to view images



    And my Wi-Fi is STILL on !!

    Please Register or Log in to view images



    Any permanent solutions ?
  2. iBricked

    iBricked Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    5,874
    Likes Received:
    39
    Device:
    iPhone 5S
    When it says wifi on in sbsettings it means that you turned it on on your ipod but not on a router. This simply means it is connecting to nothing.

    1.restart router

    2.restart ipod touch

    3.try reconnecting

    4.reprogram the router

    5. PM me if problems persist.
  3. neivin93

    neivin93 New Member

    Joined:
    Jul 4, 2009
    Messages:
    61
    Likes Received:
    0
    Device:
    3G iPod touch
    Umm, no offence, but iBricked I am not stupid !
    Obviously my router is on !

    Please Register or Log in to view images



    I put that picture up because that was the easiest way I could represent my problem...

    And no I have waited for some time after I choose the wifi network for it to authenticate and stuff so don't tell me about that also.

    I also tried your steps, but they didn't work.
    Like, I said the problem arises intermittently.
    I can use wi-fi for a while and then suddenly it conks off and I can only connect if I reboot my iPod.

    PS read what I wrote =
  4. Unregistered

    Unregistered Guest

    same problem here

    I think we should reset the firmware, also i notice this problem since i installed notifications with push doctor.

Share This Page