Installer4 Repo Help Please

Discussion in 'iOS Jailbreak & Cydia' started by Draven, Oct 5, 2008.

  1. Draven

    Draven New Member

    Sep 24, 2008
    Likes Received:
    I am setting up a private repo for me and a couple real life friends, don't want it public or anything like that, not trying to compete with others.

    I have it all running, works fine except when it installs files it puts the permissions to 0644 when they should be 0664.

    For Example: I install 'wallpaper.png' and this is how it installs, -rw-r--r-- instead of -rw-rw-r--...

    -rw-rw-r-- 1 root admin  15506 Aug 29  2007 118.thumbnail.png
    -rw-r--r-- 1 root admin 212754 Oct  5 09:17 wallpaper.png
    -rw-rw-r-- 1 root admin   7570 Dec 14  2007 poster.thumbnail.png
    I have tried using the Installer3 'Exec' command in Install.plist but that didn't work. Anybody know another way without having to do it manually?

    appearently the permissions of the .zip need to be modified on a Mac. Somebody at RiP Dev did it for me and now it works. But there must be another solution or else only Mac users can have an Installer4 Repo?

    Okay, you can zip it on any UN*X based system. I tried it on my linux server earlier today and it didn't work, but now it does.

Share This Page