Installer: Package Download Failed/Main Script Execution Failed

Discussion in 'iPod touch' started by wobgob, May 5, 2008.

  1. wobgob

    wobgob New Member

    Joined:
    Apr 24, 2008
    Messages:
    22
    Likes Received:
    0
    Device:
    iPod touch
    I HAVE searched, and tried all solutions that were given for this in previous threads, so don't flame me!

    I have a similar problem to all the other threads like this. My Installer app can't install anything. It used to say "Package Download Failed" (with no explanation why at the end) but now it says "Main Script Execution Failed".

    I have tried:

    • Reinstalling Installer
    • Reinstalling Community Sources
    • Manually checking all sources for typos
    • Changing Installer permissions
    • Clearing Installer queues (several times)
    • Rebooting iPod (several times)
    • Checking WiFi connectivity
    • Fix NVRAM via ZiPhone (this appears to have helped some people but my ZiPhone didn't have the option to do it)

    Also tried
    HTML:
    cd /
    cd Applications/
    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app
    I'm running a jailbroken ZiPhone 1.1.4 iPod touch. As you can see I've looked at all the other threads, but they haven't solved my problem.

    Help?
  2. ricardofelix95

    ricardofelix95 Banned

    Joined:
    Mar 16, 2008
    Messages:
    2,702
    Likes Received:
    4
    try clear quee
  3. wearmaize

    wearmaize Active Member

    Joined:
    Feb 13, 2008
    Messages:
    2,442
    Likes Received:
    13
    Device:
    iPhone 4S (Black)
    See my guide on youtube (link in sig).
  4. chriscoyne

    chriscoyne New Member

    Joined:
    Mar 14, 2008
    Messages:
    44
    Likes Received:
    3
    I used to have the same problem. You have done alot to try and fix. I found a sequence of Turning OFF and rebooting iPhone between Installer App installs worked. PLus try refrexhing your sources over EDGE instead of WiFi. Also, some Apps do not install because of incompatability. Install the 1.1.4 Compatibility patch before trying to install new Apps. You can find patches at www.iAppCat.com Its a repositotry of repositories. Once you can install something...switch back top WiFi.

    Hope this helps you.
  5. wobgob

    wobgob New Member

    Joined:
    Apr 24, 2008
    Messages:
    22
    Likes Received:
    0
    Device:
    iPod touch
    Tried that.

    Cheers.

    I have an iPod so I can't use EDGE, but I'll try installing the compatability patch.
  6. Khaos

    Khaos Well-Known Member

    Joined:
    Dec 31, 2007
    Messages:
    1,655
    Likes Received:
    127
    Device:
    iPhone 4 (Black)
    you entered the wrong command: you entered:

    Code:
    chown -R root:wheel Installer.app
    The real one is

    Code:
    chown -R root:wheel /Applications/Installer.app/Installer
    enter that and it should work
  7. wobgob

    wobgob New Member

    Joined:
    Apr 24, 2008
    Messages:
    22
    Likes Received:
    0
    Device:
    iPod touch
    Thanks a lot! Most packages install fine now, although there are some that still won't work, but I've put that down to a bad repo. Cheers!
  8. moosh

    moosh New Member

    Joined:
    Oct 13, 2007
    Messages:
    198
    Likes Received:
    4
    Device:
    iPod touch
    Which of the solutions ended up working? Cuz i'm having that problem too.
  9. Clifton Santiago

    Clifton Santiago New Member

    Joined:
    Mar 31, 2008
    Messages:
    45
    Likes Received:
    0
    Device:
    iPod touch
    Where is the exact location where you enter those (On windows,using WinSCP)???

Share This Page