Installer Icon Dissappeared?

Discussion in 'iPod touch' started by coby!, Feb 5, 2008.

  1. coby!

    coby! New Member

    Joined:
    Jan 11, 2008
    Messages:
    288
    Likes Received:
    1
    I just turned on my ipod and my Installer icon is gone. It shows up in customize when I go to order them, but on the springboard it doesnt. Any clue as to how to get it back?
  2. mattym

    mattym New Member

    Joined:
    Sep 22, 2007
    Messages:
    786
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    I have an idea of what you might be able to do but i will need a little while to test it.
  3. kevio

    kevio New Member

    Joined:
    Sep 15, 2007
    Messages:
    242
    Likes Received:
    0
    I went into Installer the other night and a message popped up to update to a newer version of Installer. So I did. Then as it was updating it crashed the sprintboard. Now I can't get back into Installer. Is there a way to manually copy the latest version through SSH?
  4. mattym

    mattym New Member

    Joined:
    Sep 22, 2007
    Messages:
    786
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
  5. kevio

    kevio New Member

    Joined:
    Sep 15, 2007
    Messages:
    242
    Likes Received:
    0
    Awesome thanks. I'll try it out and let you know how it goes.
  6. kevio

    kevio New Member

    Joined:
    Sep 15, 2007
    Messages:
    242
    Likes Received:
    0
    Ok, I unzipped that file and replaced /Applications/Installer.app with the new one. But it still doesn't work. When I launch it a white screen comes up as if it's going to load and then it crashes back to sprintboard. That's what it was doing before. I found another folder in /private/var/root/Library/Installer that has some plist files in it. It also has a temp folder which has the Installer.zip file in it. Do you think one of these plist files was corrupted or are there other areas in the filesystem that reference the Installer.app?
    Thanks,
    Kev
  7. kevio

    kevio New Member

    Joined:
    Sep 15, 2007
    Messages:
    242
    Likes Received:
    0
    Anyone have any ideas?
  8. Cam98

    Cam98 New Member

    Joined:
    Nov 11, 2007
    Messages:
    147
    Likes Received:
    1
    i tried that method too never worked....

    any help too cause i lost my installer totally off my springboard and wont show anywhere except if i ssh
  9. kevio

    kevio New Member

    Joined:
    Sep 15, 2007
    Messages:
    242
    Likes Received:
    0
    Ok, so this whole thing started when I tried to update to the latest version of AppTapp Installer. I manually copied the file posted by Mattym using SSH, replacing the old version. Still it didn't work. Finally, I figured out what it was. I had to go in and change the permissions to 755 for everything in /Applications/Installer and /var/root/Library/Installer. Then I was able to launch the Installer.app. Of course the first thing it's asking me is to update the installer. I go to updated it and it says there isn't enough space. Even though I have way more than enough space. Any new ideas?

Share This Page