Installer Crashes when refreshing

Discussion in 'iOS Jailbreak & Cydia' started by snpri3, Mar 31, 2008.

  1. snpri3

    snpri3 New Member

    Joined:
    Feb 17, 2008
    Messages:
    559
    Likes Received:
    10
    hmm interestingly enough i refresh my sources today and gets about 25% there and just crashes back to springboard, it was working fine yesterday , i woke up today and its different.

    i didnt mess with it i dont know why this happens, anyone have an answer to this?
  2. elmagic

    elmagic New Member

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    well, it depends on your sources... i think...
    for some reason, when a source server doesnt respond for an extended period of time, or you have too many sources, then it crashes... i have no idea why, but try this:

    Go to mobilefinder or SSH, whatever you want/can use, and go to the directory

    /var/root/library/installer

    once there, look for a file called

    "PackageSources.plist" and/or "RemotePackages.plist"

    Delete one or both. I recommend deleting the "packageSources.plist" file because then you can still uninstall all the applications that you downloaded via installer. Because when you delete the "RemotePackages.plist" file, installer has no data to tell whether or not you have any applications. You will just have to uninstall manually, due to the fact that it no longer has any record to read from.

    When you delete the "PackageSources.plist" all you are erasing is all the sources you have added, keeping the trusted sources, but getting rid of all of the ones you added yourself, manually. Then all you have to do, is find the source for Shai's "all sources", blaze, bigboss, and ipodtouchfans sources, and you will most likely have all the sources, updated and working, that you had before!
    Sorry but I just did this a week ago and i havent added all the sources back..... XD

    hope this helps, and if it doesnt, pm me and i will try to help more!

    el
  3. snpri3

    snpri3 New Member

    Joined:
    Feb 17, 2008
    Messages:
    559
    Likes Received:
    10
    its ok i think i got it, i just deleted some sources and restarted and it worked. thanx though maybe it will help someone else
  4. elmagic

    elmagic New Member

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    good!

    well even though it didn't help you, im glad it might help someone else...

    Please Register or Log in to view images

Share This Page