In need of information on iPod touch

Discussion in 'iPod touch' started by qtp998, Jan 1, 2009.

  1. qtp998

    qtp998 New Member

    Joined:
    Jan 1, 2009
    Messages:
    1
    Likes Received:
    0
    I have just gotten a new iPod touch from best buys and the firmware of the iPod touch was 1.1.5 but people are saying that when you buy a iPod touch from the stores new it should come with 2.0.1 or something. Would any of you guys know why it came with a 1.1.5 firmware.
  2. SolarFlare

    SolarFlare New Member

    Joined:
    Jul 23, 2008
    Messages:
    1,292
    Likes Received:
    0
    Device:
    iPod touch
    Probably just wasn't updated. Not a big problem; just pay for the upgrade via iTunes.
  3. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    If you bought a new one from Best Buy there is no way it should have 1.1.5! The new ipods only came with 2.1.1 and then to 2.2. You have a 1st gen iPod
  4. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    I wouldn't worry, even if you have a first gen ipod touch at least you can jailbreak it! Many 2G users would gladly swap their unit for yours I am sure!
  5. Abcmsaj

    Abcmsaj Retired Moderator

    Joined:
    Jan 26, 2008
    Messages:
    5,501
    Likes Received:
    122
    Device:
    iPhone 6 Plus
    I'd personally complain...

    If it is a 1G... get it replaced for a 2G.

    If it's a 2G with 1.1.5... It's broken. Coz the earliest the 2G can have is 2.0

    Please Register or Log in to view images

Share This Page