I'm trying to get somethings straight here

Discussion in 'iPod touch Firmware 3.0 Jailbreak' started by BlaqkLabeL, Jun 18, 2009.

  1. BlaqkLabeL

    BlaqkLabeL New Member

    Joined:
    Feb 18, 2009
    Messages:
    77
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    1) Now the the official 3.0 has been released, is the jailbreak tethered or untethered?
    1a) Also, QuickFreedom doesnt support 3.0 jb? What software do you use?

    2) Some Cydia apps won't work in 3.0? Is there a list, and they will eventually be supported, correct?

    3) Do I have to upgrade to iTunes 8.2?

    4) Right now, is it better to keep 2.2.1jb or upgrade to 3.0?
  2. kirch21

    kirch21 New Member

    Joined:
    Jul 23, 2008
    Messages:
    125
    Likes Received:
    0
    Device:
    2G iPod touch
    1. dev team is realeasing a jailbreak, its not out yet!
    2. im sure all the apps will be ported to 3.0 that are important! cydia, icy, and winterboard have been said to work, all i have heard of so far
    3. yes you have to upgrade because the 3.0 firmware requires itunes 8.2
    4. id upgrade because the jaibreak is soon to be realeased!!!
  3. zackplanet42

    zackplanet42 New Member

    Joined:
    Feb 24, 2008
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    1.the jailbreak is untethered for everything (except 3g s which isn't out yet) but it isn't released yet
    2. yes some don't work. many of them are being or have been updated to be compatible.
    3.yes itunes 8.2 is the only itunes that supports 3.0
    4.depends on if you use things that require jailbreaking. but i personally am waiting for the jb to upgrade
  4. Zerozx

    Zerozx New Member

    Joined:
    Jun 17, 2009
    Messages:
    150
    Likes Received:
    0
    Device:
    4G iPod touch
    1. It will most likely be untethered.
    1a. Windows users will use QuickPWN and Mac users will use PwnageTool

    2. I don't know if there is a list, but there probably will be a list eventually and yes, they will all eventually be upgraded to be compatible with the 3.0

    3. I've heard that you should, but I don't know if it's absolutely necessary. I would do it anyway just to be safe.

    4. I'm still on my 2.2.1 jailbroken firmware. I'll upgrade to 3.0 whenever a jailbreak is officially released, I'm just being cautious and safe. Don't want to screw anything up.

    Hope I helped...someone correct me if I'm wrong about any of this.
  5. Lally9409

    Lally9409 New Member

    Joined:
    Jan 20, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    same i'm gonna hold off on updating until the jb is released,

    if something unexpected happens and it doesn't come out by tomorrow afternoon when i get home from school, i'll just upgrade to regular 3.0, make a list of all my cydia stuff to download again though when 3.0 jb is available,

    but thats worst case scenario i have very high hopes that they'll be done by tomorrow afternoon
  6. magicalan

    magicalan New Member

    Joined:
    Jun 3, 2009
    Messages:
    46
    Likes Received:
    0
    am a noob so ill just asnwer number 4

    Please Register or Log in to view images



    i still have the 2.2 am waiting for the jailbreak to be release.. even tho i wanna c it so bad >_< *looks for excuses to upgrade*

    Please Register or Log in to view images

  7. The Killswitch

    The Killswitch Well-Known Member

    Joined:
    Mar 11, 2009
    Messages:
    1,614
    Likes Received:
    117
    Device:
    Samsung Galaxy S4
    1) Untethered.
    2) There will be updates shortly for those that aren't supported.
    3) Yes.
    4) If you want the features of 3.0, go ahead. You won't mess anything up.

Share This Page