icon's not changing

Discussion in 'Customize 2.0 Discussions' started by cameleon1267, Jun 13, 2008.

  1. cameleon1267

    cameleon1267 Member

    Oct 11, 2007
    Likes Received:
    iPhone 4 (Black)
    I always had some trouble with customize and I can't find a nice way to make it running correcly. I can always use the brute force and launch it from terminal as root and then it work just fine but this is not the way it should be.

    I should be able to run it as mobile. I symlink the var/root/Library and media folder to my var/mobile/ directory

    still no luck and nothing would change. then I started messing around with chown permission.
    I managed to change the dock and unlock screen after changing the owner and group of /System folder to mobile:mobile. but still the icon won't change because customize try to replace the png file that are in the /Applications folder and you need root access.

    then I tried: chown -Rh mobile:mobile /Applications/

    then I could change the icons but then some program like the installer will not work correctly because they need root privileges.

    sorry if I am not clear.
    The idea is to give customize root privilege even when it is launched from the mobile group.

    other people seems to have it working fine so I am probably missing something here.

Share This Page