Icons not changing

Discussion in 'iOS Themes and Customization' started by Lizabethp, Apr 21, 2010.

  1. Lizabethp

    Lizabethp New Member

    Joined:
    Apr 21, 2010
    Messages:
    1
    Likes Received:
    0
    Hello, this is my first post. The name is Lizabeth.

    Please Register or Log in to view images



    I have a iPod touch 2G 3.1.2 MC Jailbroken. For the longest time, I could change my theme and my icons would change accordingly with the theme I would apply via Winterboard. But recently, everytime I try to change my theme (including the ones that worked previously), everything changes except the icons.. and it's not just app icons, it's all of them (settings, music, weather etc). I Googled the crap out of this and could not find the answer anywhere, but Google brought me here. So hopefully I can get an answer here!
  2. J-Phone

    J-Phone Active Member

    Joined:
    Dec 1, 2009
    Messages:
    4,868
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    Try turning on summerboard mode.
  3. SilentWalker

    SilentWalker Retired Moderator

    Joined:
    Jul 26, 2009
    Messages:
    1,323
    Likes Received:
    10
    Device:
    2G iPod touch
    First, ensure that the theme is selected in Winterboard, and that the icons are in the proper folder. They should be in Library/Themes/*theme name*/Icons. You can use iFile on the iPod, or SSH or iFunBox on your computer to navigate through the file system.

    Finally, navigate to /var/mobile/Library/Caches/ then delete these 2 folders -

    SpringBoardIconCache
    SpringBoardIconCache-small

    -and then respring.

    And I'm glad that Google brought here lol

    Please Register or Log in to view images

    .
  4. Dabone

    Dabone Well-Known Member

    Joined:
    Sep 24, 2008
    Messages:
    2,231
    Likes Received:
    48
    Device:
    4G iPod touch
    It didnt work for me...
  5. SoBe

    SoBe Banned

    Joined:
    Sep 1, 2009
    Messages:
    3,788
    Likes Received:
    1
    Device:
    2G iPod touch
    This happens when running with summerboard mode off.
  6. sageDieu

    sageDieu Banned

    Joined:
    Dec 2, 2009
    Messages:
    1,036
    Likes Received:
    0
    Device:
    2G iPod touch
    Yeah I've had this problem. Enable Summerboard mode and delete the icon caches like detailed above. It worked for me. Try doing a reboot after you do that stuff. And try installing an App Store app, just a random free one and then delete it or whatever. That's fixed some icon problems i've had before.

Share This Page