I think my ipod touch is broken! HELP~

Discussion in 'iPod touch 1.1.3 Jailbreak' started by MegaIpod, Mar 2, 2008.

  1. MegaIpod

    MegaIpod New Member

    Joined:
    Dec 5, 2007
    Messages:
    102
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Hello, I have a 8gig iPod touch i think i used nates to jail break it to 1.1.3
    I saw 1.1.4 came out i downloaded ZiPhone 2.5 ran it jailbroke it still 1.1.3 so i tried the installer app that said i needed 1.1.2 so i clicked iTunes clicked shift and clicked restore clicked 1.1.1 or 1.1.2 :

    The iPod "iPod" could not be restore. An unknown error occurred (5)


    I got stuck at the itunes cabe and the itunes thingy. I tried everything i went to ZiPhone clicked DFU mode tried restoreing again! Samething! So now im stuck with a ipod touch that shows me itunes and a cable.

    Anyhelp?

    EDIT: This problem was resolved by looking at another post!

    Fix: Download the Ipod Touch Firmware meaning dont download anything that says: Iphone_somthing.
    It has to say ipod_somthing.

    Easy say: Don't use a Iphone firmware on a iPod touch!
  2. herbal77

    herbal77 New Member

    Joined:
    Jan 27, 2008
    Messages:
    53
    Likes Received:
    0
    yup i was going to tell you you put to many iphone jailbreak things on it

Share This Page