I Need Help with iComic

Discussion in 'iOS Jailbreak & Cydia' started by mikeydangerous, Dec 4, 2008.

Thread Status:
Not open for further replies.
  1. mikeydangerous

    mikeydangerous New Member

    Joined:
    Dec 4, 2008
    Messages:
    5
    Likes Received:
    0
    I'm running a jailbroken 3g on software 2.2 (though this problem was also there with 2.1 with iComic).

    Every time I try to open a comic in iComic or Comic Viewer, it will slide quickly to a black screen then right back to the directory list. I've made sure that the files are zip not cbr, in the correct directory, and I've even tried changing the permissions on the comics and the app, but it happens all the time. And, I've tried reinstalling and deleting the folders stated in the Ultimate Thread, but nothing is working.

    I was able to get the comics to work with the iPhone 2.1 software and ComicViewer, but I now neither iComic nor ComicViewer works.

    Any ideas?
  2. Jarlath

    Jarlath Retired Moderator

    Joined:
    Mar 21, 2008
    Messages:
    2,321
    Likes Received:
    0
    There's the App Store version available now... but I have to ask if you've got Gravity Slide turned on in the iComic options. Have you deleted the iComic preferences file in /var/mobile/Library/preferences? Because it really sounds like it might be turning pages automatically using the accelerometer and sending you back to the main screen as it's backed all the way out of the file.

    Also, how big are the files, sizewise, and how big are the images inside? There's a maximum allowed picture size is 2MB for the file size and 5MB for the total picture size.
  3. mikeydangerous

    mikeydangerous New Member

    Joined:
    Dec 4, 2008
    Messages:
    5
    Likes Received:
    0
    I deleted the pref files, no dice. The Gravity Slide option is turned off. The files are about 16.5MB each, so I'll try shrinking those and see what happens.
  4. Jarlath

    Jarlath Retired Moderator

    Joined:
    Mar 21, 2008
    Messages:
    2,321
    Likes Received:
    0
    Are the ZIP files 16.5MB each, or the picture files in the ZIP archives that big? If the ZIP archive's only 16.5MB, then that's not the issue. Now, if each JPEG is 16MB...
  5. mikeydangerous

    mikeydangerous New Member

    Joined:
    Dec 4, 2008
    Messages:
    5
    Likes Received:
    0
    the zip files are around 20MB actually, a couple are as big as 32MB. dunno how big the jpegs are inside
  6. Jarlath

    Jarlath Retired Moderator

    Joined:
    Mar 21, 2008
    Messages:
    2,321
    Likes Received:
    0
    That's easy to check - use WinRAR or 7Zip to open up the file and look inside at the compressed and uncompressed file sizes. If the images themselves are too large in resolution or file size, it won't work.
  7. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    Like the name mikeydangerous. We related?

    Please Register or Log in to view images



    Try downloading this comic and SSH transfer it to the <root>var/mobile/Media/Comic directory. Then we can ascertain whether it's a comic format problem or not.
  8. SalParadise

    SalParadise Member

    Joined:
    Oct 3, 2008
    Messages:
    123
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    I know this may be pointing out the obvious, but try uninstalling iComic and then reinstalling it. Sounds like it's not a file problem since they show up on your comics list and open for a second. If you never messed with the original settings of iComic, that shouldn't be the cause either.
  9. mikeydangerous

    mikeydangerous New Member

    Joined:
    Dec 4, 2008
    Messages:
    5
    Likes Received:
    0
    That comic worked fine, so I guess it is a file size problem. Thanks a lot!
  10. SalParadise

    SalParadise Member

    Joined:
    Oct 3, 2008
    Messages:
    123
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    I stand corrected.
Thread Status:
Not open for further replies.

Share This Page