I must be lucky

Discussion in 'iPod touch' started by IlluminatedTouch, Oct 8, 2007.

  1. IlluminatedTouch

    IlluminatedTouch New Member

    Joined:
    Sep 26, 2007
    Messages:
    137
    Likes Received:
    0
    I have a perfect iPod touch! Its a week 38, got it around September 25th. Nothing has gone wrong with it except with the Safari not letting me click anything, but its not a big deal. I mainly use the Touch for music/videos, and the occasional web browsing.

    I love my Touch. Anyone else with a perfect Touch?
  2. rokrboy

    rokrboy Retired Moderator

    Joined:
    Sep 29, 2007
    Messages:
    2,475
    Likes Received:
    29
    Device:
    iPod touch
    ITs the week 37's that usually have problems not the 38's. Glad your touch works so does mine.

    Please Register or Log in to view images

  3. IlluminatedTouch

    IlluminatedTouch New Member

    Joined:
    Sep 26, 2007
    Messages:
    137
    Likes Received:
    0
    I know the week 37's have the problems, but some week 38's have issues too, but I'm so happy for my Touch.
  4. Blonderator

    Blonderator New Member

    Joined:
    Sep 30, 2007
    Messages:
    77
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I do.

    I got worried when I first saw the box, cause it was one of the older model boxes.

    But when I saw the iPod, I was lucky to discover it was a week 38. Whew.

    No problems at all!
  5. AlliPodHax

    AlliPodHax New Member

    Joined:
    Sep 16, 2007
    Messages:
    698
    Likes Received:
    60
    Device:
    iPhone 3GS (Black)
    that sounds like a pretty bug problem to me?!?!

    Cheers,
    Ben.
  6. rokrboy

    rokrboy Retired Moderator

    Joined:
    Sep 29, 2007
    Messages:
    2,475
    Likes Received:
    29
    Device:
    iPod touch
    that happens to mine once ins while but if I reset my touch I'm fine.
  7. 1337chaos

    1337chaos Well-Known Member

    Joined:
    Sep 27, 2007
    Messages:
    1,375
    Likes Received:
    26
    Device:
    4G iPod touch
    that only happened to me once. fisrt day, its never happened since. so far everything on mine is absolutely perfect. no dead pixels at all, only thing im sort of mad about is it only has 7.34 GB instead of 8.
  8. plg6067

    plg6067 New Member

    Joined:
    Sep 22, 2007
    Messages:
    835
    Likes Received:
    2
    your only missing 660mb, 16gbs only have 14.84 were missing 1160mb )-:
  9. djricekcn

    djricekcn New Member

    Joined:
    Sep 29, 2007
    Messages:
    160
    Likes Received:
    0
    you're not missing that....16gb =! isn't what it really is. Computer language and Business language not the same. i.e. 120gb labeled = 111gb in computer language.


    Also, if your Safari doesn't work with links, reboot your (not restart) iPod. That fixed someone else's with the same issue.
  10. TSOnTheDrums8892

    TSOnTheDrums8892 New Member

    Joined:
    Sep 26, 2007
    Messages:
    904
    Likes Received:
    7
    Device:
    2G iPod touch
    yeah that's wrong too... When u see the 14.84 that's the formated capacity, u really r getting 16gb just not when u format it

Share This Page