I Love Katamari language problem

Discussion in 'iPod touch' started by Nial, Dec 15, 2008.

  1. Nial

    Nial New Member

    Joined:
    Aug 13, 2008
    Messages:
    5
    Likes Received:
    0
    Hopefully I'm posting in the right section. After a google search, and a search here, I'm still having problems with I Love Katamari. After purchasing the game directly from my un-jailbroken first generation iPod Touch, I booted the game to find it was set to Japanese as the default language.

    How can I go about changing it to English? On the main screen, I'm shown a planet. One of the clickable icons is a lever - which, I'm guessing, represents settings. Sadly, nothing seems to be selectable within that screen.

    Any suggestions? If anyone has a working English copy of the game, could you run me through how to go about reaching a settings menu to change the language?
  2. LovesToTouch

    LovesToTouch New Member

    Joined:
    Nov 22, 2008
    Messages:
    62
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    mines in japanese too. I am jailbroken though
    Is yours 1.1 or 1.0?
  3. kixphlat

    kixphlat Member

    Joined:
    Nov 30, 2007
    Messages:
    643
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    Make sure you have an US itunes account
  4. veeloc

    veeloc New Member

    Joined:
    Sep 6, 2008
    Messages:
    815
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    some apps r just tht way. i found one tht was in french, but it was just tht way, and idk if you can change it. but i think it's just set that way.

Share This Page