I can't upgrade

Discussion in 'iPod touch Firmware 1.1.3 Discussions' started by IlluminatedTouch, Jan 15, 2008.

  1. IlluminatedTouch

    IlluminatedTouch New Member

    Joined:
    Sep 26, 2007
    Messages:
    137
    Likes Received:
    0
    I try to upgrade to the new iTunes, and the the new iPod software 1.1.3, but it says iTunes cannot connect to the Update server...

    anyone else having this problem? I already purchased the 20 dollar thing for the 5 apps...but it doesn't sync it to my ipod....


    WHAT GIVES?
  2. rosenkrieger

    rosenkrieger New Member

    Joined:
    Dec 17, 2007
    Messages:
    4
    Likes Received:
    0
    Server overload maybe?

    You need the iTunes 7.6 before you can do anything.
  3. Steaps

    Steaps New Member

    Joined:
    Oct 24, 2007
    Messages:
    5,074
    Likes Received:
    41
    Device:
    iPod touch
    I had it, closed itunes. just opened it back up now and it had the 7.6 is availyable now blah. (It was like 5 minutes)
  4. TheRays

    TheRays New Member

    Joined:
    Sep 20, 2007
    Messages:
    70
    Likes Received:
    0
    and me, once i bought the software though it started downloading, weird eh ?
  5. IlluminatedTouch

    IlluminatedTouch New Member

    Joined:
    Sep 26, 2007
    Messages:
    137
    Likes Received:
    0
    How can I tell if I actually do have iTunes 7.6? Is there anywhere I can go to on my Itunes?

Share This Page