Huge problem with XP and Vista Drivers, please help :(

Discussion in 'Computing, Science, and Technology' started by the goat, Mar 14, 2009.

  1. the goat

    the goat Well-Known Member

    Joined:
    Nov 14, 2007
    Messages:
    1,802
    Likes Received:
    63
    Device:
    iPhone 5 (Black)
    Well until now I have had XP on my computer but I am thinking of upgrading to Vista Ultimate 32 bit. (No discussion over where/how I get this) Now I have a few questions as I have had this computer for about 4 years now, the hardware is quite old and might not support Vista. My main concern is the motherboard, but we will get to the others later, the motherboard model number is: Gigabyte GA-M55S-S3 now will this support Vista or do I have to download the drivers manually for it to work?
    As I have been on the Gigabyte website (motherboard), I found my exact model and spec, then when I click on the drivers tab for my motherboard, I have a problem, it comes up with loads of different parts of the motherboard drivers:
    Audio
    Chipset / LAN / SATA RAID
    Chipset / LAN / SATA RAID

    Now, for these 3 'parts' it has about 3-5 different drivers available to download, now which one do I download?

    Please Register or Log in to view images

    Because if the motherboard doesn't support Vista, then obviously I will have to go to this website and download the appropriate drivers for it, but my problem here is simply, which one? Because I don't know what the model nomber for my audio drivers are anyway

    Please Register or Log in to view images

    when I go into Device Manager, it doesn't say any model number, just Audio Devices, that's all

    Please Register or Log in to view images

    I am really stuck and desperate for Vista. Please help guys, it will be much appreciated

    Please check back on this thread as if I come across the same problem for graphics and internet, I will add them to the post

    Please Register or Log in to view images





    EDIT, PLEASE READ!!:

    I went and after a bit of searching I found out the motherboard supports WINDOWS VISTA PREMIUM, now will it work with Ultimate? Or do I HAVE to have Premium for it to work?

    Please Register or Log in to view images




    EDIT 2:

    Ok, so I went off and found out my graphics card model number, its Nvidia GEForce 7300 LE, will this support Vista? If so, which version(s)?


    EDIT 3:

    Ok, this is my network card link and it doesn't seem like it supports Vista, only XP and older. But if this is true and it doesn't, is there any way I could get a driver for it?
  2. buckycat

    buckycat New Member

    Joined:
    Feb 19, 2008
    Messages:
    168
    Likes Received:
    0
    I don't know :|

Share This Page