How to install iphone sdk 4 on Mac OSX 10.5.8

Discussion in 'iOS Development' started by linkou.bian@gmail.com, Aug 17, 2010.

  1. linkou.bian@gmail.com

    linkou.bian@gmail.com New Member

    Joined:
    Sep 17, 2009
    Messages:
    18
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I found following sentence in the Xcode 3.2.3 Readme (Posted: August 11, 2010 in iPhone Developer Center) -

    "Xcode 3.2 requires an Intel-based Mac running Mac OS X Snow Leopard version 10.6.4 or later."

    But my develop environment is 10.5.8 and don't plan to upgrade my system currently. How to install the latest Xcode 3.2.3 and iOS SDK 4.0.2 provided by Apple?

    Did someone ever succeed to install the latest dmg on leopard instead of snow leopard? and how?

    Thanks in advance.

    Linkou Bian
    Email/MSN: linkou.bian@gmail.com
  2. macsplash

    macsplash New Member

    Joined:
    Aug 15, 2010
    Messages:
    49
    Likes Received:
    0
    - Impossible
  3. Disappointing...

    I'm facing the same issue... how to develop iphone apps with Mac OS X 10.5?!
  4. elamre

    elamre Member

    Joined:
    Feb 2, 2009
    Messages:
    551
    Likes Received:
    11
    Device:
    4G iPod touch
    i think, if i recall correctly, that 3.2 works. so you might want to search the xcode with 3.2. no idea where you can find it though. i only remember doing it on my mac which was on 10.5.6

Share This Page