How to get installer?

Discussion in 'iPod touch' started by bduster, Dec 1, 2007.

  1. bduster

    bduster New Member

    Joined:
    Nov 4, 2007
    Messages:
    3
    Likes Received:
    0
    I tried to reinstall the installer application through the uninstall tab. It stopped in the middle of it and went back to the main screen. I am assuming it uninstalled half of the files. So when I tried to open the installer application, it shows a white screen and goes back to the main menu. There is no way to open it. Is there any way to reinstall installer again or do I have to resort to restoring my iPod Touch?
  2. Scythal

    Scythal New Member

    Joined:
    Nov 27, 2007
    Messages:
    413
    Likes Received:
    4
    Device:
    iPod touch
    Have you checked about the memory limitation? (cfr. your first post)

    Anyway, once you've uninstalled the only program allowing you to install programs, I'm not sure how you will pull off this one

    Please Register or Log in to view images



    Normally you should still have the ssh daemon running, so you can try to put back the files manually with WinSCP or sFTP.
    • You can download the Installer from this location:
      [u]http://repository.apptapp.com/packages/System/Installer.zip[/u]
    • Unzip the files.
    • Start WinSCP or sFTP, log onto your iPod (search in the forums if you don't know how to, there's a guide somewhere).
    • Check the /Applications directory (which should in fact be a link to /private/var/Applications if you solved the memory limitation issue above). There should be some remainings of the Install.app, you can leave them there.
    • Copy the Install.app directory you unzipped on your PC to the /Applications directory of the iPod. Confirm the overwrite if asked for.
    • Enter the Install.app directory on your iPod with WinSCP / sFTP and check the permissions on the Installer file, it should be 0755: modify them if necessary. Same for AppTapp under the AppTapp.framework subdirectory. In doubt, you can put the 0755 permissions on the Install.app directory and ask to apply those settings recursively.
    • Close the WinSCP / sFTP session, and try your new Installer. If it doesn't show in the menu anymore since your uninstall, lock/unlock the iPod, or reboot it completely.

Share This Page