iOS 3.1 How I got around the 1603 error

Discussion in 'iOS Jailbreak & Cydia' started by mcchots, Oct 5, 2009.

  1. mcchots

    mcchots New Member

    Joined:
    Jun 10, 2009
    Messages:
    2
    Likes Received:
    0
    Device:
    2G iPod touch
    Hi,

    I have been having trouble upgrading from 2.2.1 to both 3.0 and 3.1.1 from the day 3.0 was released. I kept on getting mostly the 1603 error and 1604 along with other ones occasionally.

    Both 3.0 and 3.1.1 would fail and leave the device in restore mode. I tried all the suggestions on the apple website and here and many other places as well.
    I noticed 3.0 would give me a progress bar before failing but 3.1.1 only ever showed the apple logo.

    I must have tried about 20 updates over the weekend before giving up and restoring 2.2.1 which was the only one that ever worked.

    So today I said f$#k it and settled for jailbreaking 2.2.1. That went well and I was satisfied for about 3 minutes before thinking "Lets give it one more go" - I'm a sucker for punishment.

    Blistering barnacles, it bloody worked the first time(actually about the 23rd

    Please Register or Log in to view images

    ).

    Hopefully this wasn't just my luck and will work for others too.
  2. iPhondTouch3G

    iPhondTouch3G Banned

    Joined:
    Oct 7, 2008
    Messages:
    659
    Likes Received:
    0
    Device:
    3G iPod touch
    Use ireb from ih8sn0w. it let's you install any firmware.

Share This Page