here are the USA Tmobile MMS settings....

Discussion in 'iPhone' started by germ, Jun 23, 2009.

  1. germ

    germ New Member

    Joined:
    Dec 25, 2008
    Messages:
    211
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    ***** please read my entire post before attempting anything*****



    please only do this if you have updated to the 3.0 firmware ONLY.


    FOR BETTER MMS PICTURE QUALITY, FOLLOW THESE STEPS....



    2g users need to get Activatemms2g from cydia for any of this to work.


    make sure that MMS is turned ON in in General>Messesages>MMS Messaging


    download the zip file from this link... http://www.box.net/shared/bot529enms ... this is a list of .ipcc files that have currently been offered by a nice member over on modmyi.com. all you will need to do is extract the files to a new seperate folder and thats it. credit to this post here.... http://www.modmyi.com/forums/t-mobile/656651-t-mobile-usa-carrier-bundle.html



    For Windows users(I did mine on Windows 7 RC1 Build 7100), follow these directions to get your phone updated....


    If running iTunes shut it down

    if you are on iTunes 8.2, you will need to open up a RUN command line (should be in your start menu). type in the following EXACTLY as shown (yes, the " as well) and hit enter....

    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt carrier-testing 1

    after doing that, you should hear your computer hard drive "working". if you get an error message like some directory is not found, sorry, i cant help with that. no error message should indicate your good to continue. If running and older version of iTunes, you should skip this step, as you dont need to change the settings.


    next, turn on iphone if not already on, plug into PC and open up itunes and click on your iphone icon on the left.

    hold down the "SHIFT" key and then click on UPDATE in iTunes.

    navigate to where you extracted all of those files before, click on the one that best describes your phone service plan with Tmobile (ie. prepay, postpay, etc). click ok, or continue or whatever it is.

    your phone will now say "Sync in Progress" or something to that nature.

    when that screen is gone, and the itunes updating screen is gone, unplug your iphone.

    now you need to REBOOT the phone (not just restart it). to reboot, you hold down the power and home button until the phone shuts down AND the Apple logo (or pineapple logo) shows up, then let go of both buttons.

    after the phone is done rebooting and has finished detecting your carrier, you will need to verify that the camara icon is in the text message as an option (the icon is to the left of where you type). send a test picture to yourself. check the quality on the mms picture that you recieve back.

    now check your internet and make sure that its working to.

    **** if your phone doesnt locate your carrier or does not show the camara icon in the text message, RESTART your phone, (dont reboot), just shut the phone off like normal and restart it.****

    after doing all of this, and you find that the settings didnt work, you will need to try one of the other .ipcc files.

    basically, start over at the step where you "plug in the iphone". be sure to reboot and restart the phone if needed EVERY TIME you change the settings.

    personally, i had to check 3 .ipcc files before i found one that worked for both MMS and the internet and all is working very well.

    Total time spent doing the aformentioned steps = less than 5mins



    some users are have issues getting this to work. there does seem to be some app conflicts that may not allow you to send or recieve mms.

    **** there is a conflict with the app named SNAPTELL with sending and recieving MMS, if you wish to use MMS, do NOT install SNAPTELL from the app store, you will NOT be able to use MMS. Until SNAPTELL is updated anyway **** if you experience problems with these settings, trying restoring and re jailbreak and redo ultrasnow and add the settings for mms FIRST, then start adding your apps until you find out which one is causing the problem.




    _____________________________________________________________________________________

    here are the settings if you just want to just set up MMS. these settings do not change the way tmobile classifies your phone and the quality will be quite lacking. but, the settings do work and its easy to change.

    go to Settings>General>Network>Cellular Network...

    change the MMS setion to the following...

    APN: wap.voicestream.com or epc.tmobile.com or wap.tmobile.com (depending on your data plan)
    Username: leave this blank
    Password:leave this blank
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:leave this blank
    MMS UA Prof URL:leave this blank


    be sure to reboot (hold down power and home until the apple or pineapple appears)
  2. OneFan

    OneFan Active Member

    Joined:
    Feb 25, 2008
    Messages:
    949
    Likes Received:
    67
    Device:
    iPhone 4 (White)
    Can anyone else confirm this.
    Does this also cost any extra fee on the phone bill??
  3. ianoreo

    ianoreo Member

    Joined:
    Sep 18, 2007
    Messages:
    471
    Likes Received:
    26
    Device:
    iPhone 5 (Black)
    Was just about to post these myself. I'm testing outgoing/incoming now.

    EDIT: Also to respond to your question on billing, if your plan supports MMS then it will cost the amount the plan has designated. On my t-mobile plan, the MMS do not fit under the unlimited texting plan I have but rather cost a certain amount per message, depending on your plan.

    Ian
    ------------------double post merged------------------
    Alright...I've waited for a few minutes after sending a picture to myself...nothing so far. I also had a friend send me one but I haven't received that either. Germ how did your's work?
  4. germ

    germ New Member

    Joined:
    Dec 25, 2008
    Messages:
    211
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    mine worked perfectly and was sent/rec'd within 1 min.


    double check what you entered to make sure its correct.

    it should be updated in Settings>General>Network>Cellular Data Network> and then under the MMS section.

    for the "Cellular Data", that is for interent, and if you dont have a VPN acct with Tmobile, then your setting should be "internet2.voicestream.com"

    the MMS settings are right below that.


    make sure that MMS is turned ON in in General>Messesages>MMS Messaging.
  5. ianoreo

    ianoreo Member

    Joined:
    Sep 18, 2007
    Messages:
    471
    Likes Received:
    26
    Device:
    iPhone 5 (Black)
    It looks like my settings are identical...I use the 5.99 internet plan...Would this interfere with the settings?
  6. TNguyen9175

    TNguyen9175 New Member

    Joined:
    Jan 15, 2009
    Messages:
    45
    Likes Received:
    0
    This does not work for me. Is there a video tutorial on how to approach this?
  7. ianoreo

    ianoreo Member

    Joined:
    Sep 18, 2007
    Messages:
    471
    Likes Received:
    26
    Device:
    iPhone 5 (Black)
    That might be nice as I am having issues as well. Where did you find these settings?

    CORRECTION! It's working now

    Please Register or Log in to view images

  8. TNguyen9175

    TNguyen9175 New Member

    Joined:
    Jan 15, 2009
    Messages:
    45
    Likes Received:
    0
    Where'd you enter in all the codes? Please help!
  9. ianoreo

    ianoreo Member

    Joined:
    Sep 18, 2007
    Messages:
    471
    Likes Received:
    26
    Device:
    iPhone 5 (Black)
    Settings>General>Network>Cellular Data Network> and then under the MMS section.
  10. TNguyen9175

    TNguyen9175 New Member

    Joined:
    Jan 15, 2009
    Messages:
    45
    Likes Received:
    0
    Did. Then what?

Share This Page