Help

Discussion in 'iPod touch' started by sidthahellraiser, Dec 24, 2007.

  1. sidthahellraiser

    sidthahellraiser New Member

    Joined:
    Dec 7, 2007
    Messages:
    88
    Likes Received:
    0
    Device:
    iPod touch
    Guys my ipod touch version is 1.1, in itunes i get an option of upgrading it to 1.1.2 but when i download n m anout to install d package i get an error that d ipod version cannot be upgraded...i think i have to upgrade the version to 1.1.1 first...but where do i download it from??( coz itunes shows only version 1.1.2)

Share This Page