Help!

Discussion in 'iPod touch' started by lilballer123, Oct 16, 2008.

  1. lilballer123

    lilballer123 New Member

    Joined:
    Oct 16, 2008
    Messages:
    48
    Likes Received:
    0
    Is it possible to use Cydia on a jailbroken iPod Touch v1.1.1??
  2. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    Yes, but make sure it is the right verison.
  3. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    You might want to upgrade to something a little less archaic by the way.
    Plus cydia was AWFUL for the 1.1.X firmwares.
  4. lilballer123

    lilballer123 New Member

    Joined:
    Oct 16, 2008
    Messages:
    48
    Likes Received:
    0
    So what's the best version to use Cydia on? Also I am on v1.1.1, which one do I download??
  5. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    Buy 2.1 and upgrade to that. I think it's probably the best at the moment.
  6. Atl

    Atl New Member

    Joined:
    Jun 20, 2008
    Messages:
    592
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Installer used to be better back in the way back era. So you should go with Installer.
  7. lilballer123

    lilballer123 New Member

    Joined:
    Oct 16, 2008
    Messages:
    48
    Likes Received:
    0
    But with Installer can I get all those crazy themes and all the customizations?? If so where?? Which catagorie??
  8. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    You won't have any new applications coming your way though, when I was back on 1.1.4 about half a month ago, things were completely dried up.

    2.X is the place to be now if you want new stuff.
  9. lilballer123

    lilballer123 New Member

    Joined:
    Oct 16, 2008
    Messages:
    48
    Likes Received:
    0
    Well do I have to buy v2.1? Also how can I jailbreak it? Is it safe?? Thanks for answer my questions!
  10. iPTF_BROWSER

    iPTF_BROWSER Active Member

    Joined:
    Aug 17, 2008
    Messages:
    1,623
    Likes Received:
    20
    Device:
    HTC One
    Yes it does. But I would say upgrade to 2.1. And yes you have to buy it for $9.99. You won't regret it!

Share This Page