Help with a winterboard theme.

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by jack.misner@virgin.net, Aug 11, 2008.

  1. jack.misner@virgin.net

    jack.misner@virgin.net New Member

    Joined:
    Jul 22, 2008
    Messages:
    473
    Likes Received:
    0
    Device:
    iPod touch
    I have winterboard installed and running correctly on 2.0 and all is well.
    the theme i am using is called "time of day"
    i dont like the bar colour that is at the top with the artist and song when music is playing and i know the way to change it back to the default is to delete the custom image from the time of day theme folder,
    the only problem i, i cant find the theme folder.
    this is confusing me because the rest of the themes that i have downloaded are in /private/var/mobile/Library/SummerBoard/Themes/
    the only theme that isnt there is Time of day.
    does anybody know where it might have installed to?
  2. owie007

    owie007 New Member

    Joined:
    Nov 29, 2007
    Messages:
    453
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    you can find it under /private/var/stash/Themes.xxxxxx
    where xxxxx will be the random stuff cydia generated when moving them...

    also, if you want to change that bar remove this from the Info.plist

    <key>NavigationBarStyle</key>
    <string>0</string>


    and save the file...

    please use at your own risk
  3. jack.misner@virgin.net

    jack.misner@virgin.net New Member

    Joined:
    Jul 22, 2008
    Messages:
    473
    Likes Received:
    0
    Device:
    iPod touch
    ok the odd thing is that it already set to "0"
    the bar colour though is a blue colour, i just want it to be the default black
  4. Manic Nimrod

    Manic Nimrod Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    8,769
    Likes Received:
    149
    Set it to '1'

    Its like that in the default blaack nav bars info.plist that came with winerboard.

    Make a backup, just incase.
  5. owie007

    owie007 New Member

    Joined:
    Nov 29, 2007
    Messages:
    453
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    what i did was completely remove it[<key>NavigationBarStyle</key><string>0</string>] from the Info.plist that came with Time of Day... it seems fine, no problems encountered yet... coz if you set it to 1 including the thirdparty apps that has a different Navigation bar will end up having a black one...

    Please Register or Log in to view images

    Please Register or Log in to view images

  6. jack.misner@virgin.net

    jack.misner@virgin.net New Member

    Joined:
    Jul 22, 2008
    Messages:
    473
    Likes Received:
    0
    Device:
    iPod touch
    well both removing the lines that say <key>NavigationBarStyle</key><string>0</string> and changing it to <key>NavigationBarStyle</key><string>1</string>
    both make every bar black. is there a way just to make the bar that appears in now playing black like it used to be?
  7. owie007

    owie007 New Member

    Joined:
    Nov 29, 2007
    Messages:
    453
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    what i did was remove those lines, and of course you need to respring your device,
    as you can see from the pictures above, the first image is where i have deleted those two lines from the Info.plist... the second one is where i set it to 1
  8. jack.misner@virgin.net

    jack.misner@virgin.net New Member

    Joined:
    Jul 22, 2008
    Messages:
    473
    Likes Received:
    0
    Device:
    iPod touch
    of course i know to respring my ipod. i do that out of habit after anything i change. both methods still have the same effect.
  9. owie007

    owie007 New Member

    Joined:
    Nov 29, 2007
    Messages:
    453
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    really? i'm sure the problem is within the theme's Info.plist...
    the workaround works fine on my ipod...
  10. ELLDAWG

    ELLDAWG Banned

    Joined:
    Feb 1, 2008
    Messages:
    814
    Likes Received:
    9
    Device:
    iPhone 3GS (Black)
    changing the info.plist file worked for me


    I changed this

    <key>NavigationBarStyle</key>
    <string>0</string>




    to this

    <key>NavigationBarStyle</key>
    <string>1</string>



    cheers

    Please Register or Log in to view images

Share This Page