help please!!! my paid for apps won't work on jailbroken 3.0 ipod

Discussion in 'iOS Jailbreak & Cydia' started by csknight123, Aug 12, 2009.

  1. csknight123

    csknight123 New Member

    Joined:
    Aug 12, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    hey i really need some help...

    so i've just upgraded to the 3.0 software and then jailbroke it with redsnow, however when i sync up all my paid for apps, none of them work.... but the default ones like music, pics, weather and such work just fine.

    when i try to open an apple signed app (like zombieville), a the openning loading screen pops up for literally one second then it cuts out. as if the app had crashed

    but apps i've downloaded from cydia work fine though...(categories, and winterboard)

    so instead of trying the easy way and begging for help immediately from you ipod Gods, i restored my ipod and did the process over again... 4 times

    Please Register or Log in to view images



    oh and when i restore it to just the 3.0 software without jailbreaking it, the apps work fine!!! i have no idea what is going on.... please, please, please help


    *****this is an edit to my post above*****
    now the apps won't even work when i've restored it....not even jailbroken....this royally sucks
  2. kyle hultgren

    kyle hultgren Member

    Joined:
    Apr 15, 2009
    Messages:
    609
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    are you sure they are paid for.... or are you lying
  3. Xii

    Xii New Member

    Joined:
    Sep 9, 2008
    Messages:
    1,147
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Download the App again?

    If you already paid, there's no reason why it should charge you.
  4. JIMIneitor

    JIMIneitor Banned

    Joined:
    Feb 21, 2009
    Messages:
    1,125
    Likes Received:
    5
    Device:
    4G iPod touch
    Xii is right, but its still annoying to have to download them all over again
  5. nozz

    nozz Member

    Joined:
    Feb 14, 2009
    Messages:
    236
    Likes Received:
    0
    Re-activate your iTunes account on your computer and then sync. The apps should work again. You could also deactivate the Apple Kill Switch with SBSettings. The outcome should be the same.
  6. Schtac

    Schtac Member

    Joined:
    Jul 5, 2009
    Messages:
    157
    Likes Received:
    0
    Device:
    2G iPod touch
    Yeah, try to reactive you account through iTunes or just delete one paid app and redownload it, it should be free
  7. Cat Of Mini Mu

    Cat Of Mini Mu Banned

    Joined:
    Aug 11, 2009
    Messages:
    63
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    ^do what nozz said, or just destroy your springboard cache and let it rebuild.

    worked for me.
  8. csknight123

    csknight123 New Member

    Joined:
    Aug 12, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    positive their paid for, i dished out over 70 bucks for them... now none of them work....
  9. Cat Of Mini Mu

    Cat Of Mini Mu Banned

    Joined:
    Aug 11, 2009
    Messages:
    63
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    well try one of the solutions we have so graciously provided you with.
  10. csknight123

    csknight123 New Member

    Joined:
    Aug 12, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    how do i do that?

Share This Page