Help me out please?!

Discussion in 'iPod touch' started by xdope, Jul 14, 2010.

  1. xdope

    xdope New Member

    Joined:
    Jul 14, 2010
    Messages:
    5
    Likes Received:
    0
    I Have a 2g iPod at the version of it out from the box is 2.2.1 and I've already jailbroke it. I want to upgrade to 3.1.2 and I keep on getting not compatible bla2. and I've already downloaded 3 same firmwares from different sites, and I've read something to upgrade to 4.0 and then downgrade to 3.1.2 which worsen my case.
    I cant jailbreak it and i cant downgrade it.. can someone help me please? It always appears that the firmware is not compatible..
    but im pretty sure it is the correct firmware. Help me out please?!

    Please Register or Log in to view images



    Thanks in advance.
  2. bobby681

    bobby681 Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,588
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Make sure the filename of the firmware starts with iPod2,1. If it starts with something else, its for a different device
  3. xdope

    xdope New Member

    Joined:
    Jul 14, 2010
    Messages:
    5
    Likes Received:
    0
    it is 2,1 i downloaded them here which i believe that the firmware is correct..
  4. Nickmadkiller

    Nickmadkiller Well-Known Member

    Joined:
    May 16, 2010
    Messages:
    4,274
    Likes Received:
    84
    Device:
    iPhone 4 (White)
    Have you tried the restore option while upgrading?When I upgraded to the 4.0 iOS I had to restore to get it to work.

    Seemed that the firmware didn't want to upgrade without restoring..but restoring was smart upgrading to 4.0.Kills many bugs while upgrading...

    You may need to go to the 4.0 and then downgrade to 3.1.2..

    It's pretty easy and simple.Try using some of the tutorial's if you need extra help.
  5. xdope

    xdope New Member

    Joined:
    Jul 14, 2010
    Messages:
    5
    Likes Received:
    0

    I guess it's not simple in my case.
    I downloaded 3 3.1.2 Firmwares but still i receive "Not compatible what so ever" that is my problem. I've googled and watched some vids in youtube but still, i cannot find the answer for my problem and im pretty sure i have the correct firmware for my ipod touch 2g
  6. mrez

    mrez Member

    Joined:
    Jul 23, 2008
    Messages:
    145
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    are you shift clicking on restore or update? it should be on restore
  7. xdope

    xdope New Member

    Joined:
    Jul 14, 2010
    Messages:
    5
    Likes Received:
    0

    yes. I even tried in in DFU mode.
  8. xdope

    xdope New Member

    Joined:
    Jul 14, 2010
    Messages:
    5
    Likes Received:
    0
    bummmp.!

    help me out guys.

Share This Page