Help jailbreak old 1.1.5 please

Discussion in 'iPod touch' started by menacepod, Jul 20, 2010.

  1. menacepod

    menacepod New Member

    Joined:
    Jul 12, 2010
    Messages:
    6
    Likes Received:
    0
    Hello all, I have a old 1.1.5 i pod and it sucks and i really want to jailbreak it, ( and yes im too cheap to get a new one lol) So if anyone could please help me, please????

    Please Register or Log in to view images

    ps im running windows 7 starter on my laptop, and im not all that computer friendly but I know the basics
  2. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Update to 3.1.3 and jailbreak with spirit.
  3. menacepod

    menacepod New Member

    Joined:
    Jul 12, 2010
    Messages:
    6
    Likes Received:
    0
    I tunes wont let me update it says its the current version
  4. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    DFU mode. And what iTunes version are you on?
  5. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    update itunes then hit upgrade iPod.
  6. bobby681

    bobby681 Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,588
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    You'll have to pay for the upgrade to the latest firmware, just warning you.
  7. menacepod

    menacepod New Member

    Joined:
    Jul 12, 2010
    Messages:
    6
    Likes Received:
    0
    I updated I tunes this morning, when I chech for update it says it has the current version,, ?
  8. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Shift restore to 3.1.3.
  9. menacepod

    menacepod New Member

    Joined:
    Jul 12, 2010
    Messages:
    6
    Likes Received:
    0
    I have i tunes 9.2.1 , so I need 3.1.3 ? and thanks for the help

Share This Page