HELP! iPod Touch 3.0 updating problem!

Discussion in 'iPod touch' started by bfolkrod, Jul 16, 2009.

  1. bfolkrod

    bfolkrod New Member

    Joined:
    Jan 14, 2009
    Messages:
    75
    Likes Received:
    0
    Device:
    2G iPod touch
    OK so here's my problem I bought 3.0 firmware for iPod Touch 2G on my dad's mac I was all like "yayay!" The next day I decide to jailbreak 3.0 using redsn0w 0.7 but my dad won't let me have redsn0w on his mac so I use the macbook pro (mac laptop) I then screw up the jailbreak process and restore my iPod Touch I click restore from backup on the laptop and my iPod Touch goes back to 2.2.1!!!!! WHAT DO I DO!?!?! Do I restore my iPod Touch on my dad's mac? I don't want to have to buy 3.0 AGAIN and also it won't let me hold shift and click restore and choose an ipsw file! :S PLEASE HELP!
    *****EDIT*****
    I FIXED IT NO NEED TO READ!!! I just connect my iPod Touch to my Dad's Mac and it suggested I update to 3.0 without paying because I already did... =) Also for some reason my redsn0w 0.7 didn't work when I tried suing it to jailbreak 3.0.... I followed the directions exactly but it wouldn't reboot...

Share This Page