Help!!!!!!!I touch Won't sync and blackra1n wont work

Discussion in 'iPod touch' started by jefw123, Jan 14, 2010.

  1. jefw123

    jefw123 New Member

    Joined:
    Jan 14, 2010
    Messages:
    1
    Likes Received:
    0
    Device:
    3G iPod touch
    Hi guys!

    Sorry to bother you but i need some serious help.I was on my i touch and I tried to restore it however it failed with an error message saying sorry your firmware is not supported.THis is probably because blackra1n.So I start my i touch up again and it tells me to put my i touch into itunes.So I run the blackra1n program and geohots pic goes onto my i touch but he never goes away.When plug my i touch in itunes doesn't find it.So is there a program which I can use which can restore my i touch or is there another method.

    I cant get onto the menu of my i touch and itunes wont work.I have jailbroken my new i touch 32gb from christmas with blackra1n and it is firmware 3.1.2 I am using windows 7 but my friend also has a mac.Please help me soon otherwise my Mum will be so pissed with me as it is new and I will be dissapointed as it wont work!

    Thanks in advance!
  2. Der-Kleine

    Der-Kleine Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,314
    Likes Received:
    24
    Device:
    Samsung Galaxy S2
    DFU mode?
    (Press and hold home + power button for 10 sec. and then keep holding the home button for 10 sec. I think)
    I hope it works for you then!

    Please Register or Log in to view images

Share This Page