Help - Can't Use iTouch

Discussion in 'iPod touch' started by delvecchio, Dec 28, 2007.

  1. delvecchio

    delvecchio New Member

    Joined:
    Dec 28, 2007
    Messages:
    1
    Likes Received:
    0
    So I got a great new iTouch (8gb) for Christmas, but unfortunately, my old iMac is still running 10.3.9 and I need 10.4.1 to use the iTouch on my home computer. I was going to buy Leopard but I don't have enough internal RAM and the thought of having to blow an additional couple hundred bucks to get my iTouch working is not ideal right now. So I'm looking for Tiger but can't find it ANYWHERE. I'm at my wit's end about this so if anyone has a lead on where I can get a copy of it, I'd be truly grateful.

    Thanks,
    -D

Share This Page