[Help A.S.A.P.] iPod Not Retoring Error (1604)

Discussion in 'iPod touch' started by iPod Touch™, Apr 14, 2009.

  1. iPod Touch™

    iPod Touch™ Banned

    Joined:
    Jan 28, 2009
    Messages:
    986
    Likes Received:
    1
    Device:
    4G iPod touch
    Ok so i have y friend sipod touch 2G that had OS 3.0 and my firend gave it to me cuz he said their was something wrong. So when i plug it into itunes it gives the connect to itunes logo and it goes strait into Recovery mode, but it wont restore. I was planning on useing quick freedom to jailbreak it to 2.2.1 (Jailbroken) is their anything i can do to get it to restore?
    ------------------double post merged------------------
    btw it got error (1604) WHEN TRYING TO RESTORE.
  2. Jacob

    Jacob Well-Known Member

    Joined:
    Mar 2, 2009
    Messages:
    4,943
    Likes Received:
    122
    1. Try to get it into DFU mode.
    2. Restore in DFU mode.
    And what does it do when not connected? Does it turn on?
  3. iPod Touch™

    iPod Touch™ Banned

    Joined:
    Jan 28, 2009
    Messages:
    986
    Likes Received:
    1
    Device:
    4G iPod touch
    Yes it turns on, ok my next attempt was to restore it in DU mode should i try to jailbreak it? Like run quickfreedom and try to restore to custom iPSW?
  4. Jacob

    Jacob Well-Known Member

    Joined:
    Mar 2, 2009
    Messages:
    4,943
    Likes Received:
    122
    Either that or download another copy of 2.2.1.
  5. Nathan B

    Nathan B Active Member

    Joined:
    Dec 12, 2008
    Messages:
    3,061
    Likes Received:
    0
    Device:
    iPhone 5 (Black)
    Yes, run the pre-jailbreak commands up to where you get a white screen, then restore in iTunes
  6. iPod Touch™

    iPod Touch™ Banned

    Joined:
    Jan 28, 2009
    Messages:
    986
    Likes Received:
    1
    Device:
    4G iPod touch
    ok thanks

    Please Register or Log in to view images


    ------------------double post merged------------------
    ok I got white screen i put into dfu this time and restored should be fine if not then Ill run pre-jailbreak and restore

    Please Register or Log in to view images


    ------------------double post merged------------------
    ok ist all good i restored to 2.2.1 now im jailbreaking it thansk guys really good nice help

    Please Register or Log in to view images

  7. Nathan B

    Nathan B Active Member

    Joined:
    Dec 12, 2008
    Messages:
    3,061
    Likes Received:
    0
    Device:
    iPhone 5 (Black)
    No problem

    Please Register or Log in to view images

  8. mbaichikov

    mbaichikov New Member

    Joined:
    Mar 22, 2009
    Messages:
    62
    Likes Received:
    0
    anothe problem could be if you are using 64bit when installed libusb on 64bit without the proper way i got that error i went to a different computer and fixed it
  9. eladc

    eladc New Member

    Joined:
    Feb 7, 2009
    Messages:
    593
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    He already fixed it..
    Read the other posts before you post.

Share This Page