Great...not again

Discussion in 'iPod touch' started by C4NNIBAL, Jun 4, 2009.

  1. C4NNIBAL

    C4NNIBAL Member

    Joined:
    Dec 18, 2008
    Messages:
    434
    Likes Received:
    23
    Device:
    iPhone 4 (White)
    Terrific. I have another problem with my iPod, as if I didn't have enough already. Okay, here it goes:
    My iPod has been working fine for the past few months, no problems (except for a bad font) and all's going well until 5 minutes ago. My iPod died this morning because I fell asleep while browsing Cydia. I went to plug it in to my computer to charge and I get this message from iTunes: "iTunes could not connect to the iPhone 'iPod' because an invalid response was recieved from the device." I had never heard of this happening before, so here I come to you guys. The only problem I could this of was if I had upgraded to iTunes 8.2 (what with all the drivers and bad communication over USB), but I haven't. What could be my problem, and can I fix without restoring my iPod (for the 5th time in 6 months)?
  2. Ryuzaki

    Ryuzaki Active Member

    Joined:
    Feb 4, 2009
    Messages:
    2,316
    Likes Received:
    1
    Device:
    iPhone 5 (Black)
    Try a wall charger or a different USB port.
    It's not a flaw flaw and you shouldn't have to restore because of it.
    Just a mess up in a connection that was bad.
  3. C4NNIBAL

    C4NNIBAL Member

    Joined:
    Dec 18, 2008
    Messages:
    434
    Likes Received:
    23
    Device:
    iPhone 4 (White)
    Thanks, tried a different USB port and it was fine. Don't know why that happened though. It did stay on the boot screen for a really long time, but I don't know if that has to do with the problem.

Share This Page