Giving MobileStudio.app (App Store) full root access on Firmware 3.0

Discussion in 'iPod touch Firmware 3.0 Jailbreak' started by deleted account, Jun 21, 2009.

  1. I found a TUT for 2.2.x which gave the following instructions:

    1. SSH into your iPod or start Terminal
    2. type cd /var/mobile/Applications
    3. type ls *
    4. find the folder (XYZ) with MobileStudio.app
    5. type cd XYZ
    6. type chmod 777 MobileStudio.app
    7. if you use Terminal, type su, then enter your root password (alpine)
    8. type cp MobileStudio.app /Applications
    9. if you made links in the Documents folder before, delete them!
    10. type mkdir /var/mobile/Documents
    11. type chmod 777 /var/mobile/Documents
    12. cd /var/mobile/Documents
    13. type ln -s / root
    14. type ln -s /var/mobile
    15. on your Springboard, go to "wiggle" mode and delete MobileStudio
    16. restart your iPod, there you go!

    I had once used that on 2.2 and it worked like a charm for me: I simply loved beeing able to download videos via Safari, unrar them via Terminal and copy/edit/watch them via MobileStudio (with REAL access to /private/var/mobile/Media/Downloads). The really cool thing was that in MobileStudio "Home" would take you directly to /private/var/mobile/Documents - this made file transfers via Total Commander so much easier, since you didn't have to search for that crpytic directory anymore. Furthermore, this was just NEAT ;-) BUT I NOW CAN'T GET THIS WORKING ON 3.0

    Please Register or Log in to view images



    There may be a connection to the fact that on 3.0 MobileStudio you can't edit permissions (or any properties) of files anymore - even in its own "sandbox" when you haven't started modding anything yet! The toggles (on the right, next to file name) just don't work anymore. Hopefully the developers provide an update soon...


    THE MAIN PROBLEM following the instructions above occured at step 7:

    In WinSCP's Terminal the command "su" had no effect at all. According to my computer screen nothing had happened. So I tried step 8 (copying MobileStudio.app to /private/var/stash/Applications.pwn) - but it didn't work.

    I then tried copying via WinSCP GUI (drag & drop). Afterthat I changed all crucial permissions via WinSCP to 0777 and created the simlinks in WinSCP. This way I got root access, and I could also start the App from /private/var/stash/Applications.pwn - "transforming" the App Store App to a jailbroken one seemed to have worked so far. BUT WHEN I TRIED EDITING ANY FILES IT DIDN'T WORK

    Please Register or Log in to view images



    Finally, I tried doing everything via Terminal.app directly on my iTouch: Here the "su" command had the desired effect and I had enter my password ("alpine"). BUT WHEN I TRIED STEP 8 I GOT THE SAME ERROR AS BEFORE: "OMITTING ..."

    Please Register or Log in to view images



    ANY IDEAS?!?!!?
  2. dc168

    dc168 New Member

    Joined:
    Jun 21, 2009
    Messages:
    1
    Likes Received:
    0
    install both openssh and mobileterminal on your iphone, on your iphone open terminal
    and input the following command:

    login root

    then input alpine as the password

    iPhone:~ root# cd /User/Documents
    iPhone:/User/Ducuments root´╝â ln -s / home
    iPhone:/User/Ducuments chown -R root:wheel /Applications/MobileStudio.app

    quit terminal and open mobilestudio and you should see a folder called home, open it and you are in business! hope this helps! Nice and easy!
  3. Jpoky

    Jpoky New Member

    Joined:
    Sep 13, 2008
    Messages:
    37
    Likes Received:
    0
    Device:
    2G iPod touch
    Returns error

    I followed these instructions, and all of the commands work except for the last one. I get this error:

    cannot access '/Applications/MobileStudio.app': No such file or directory

    I definately have MobileStudio from the app store installed. Any ideas?

    Thanks
  4. tritran18518

    tritran18518 New Member

    Joined:
    Feb 2, 2009
    Messages:
    93
    Likes Received:
    0
    Device:
    2G iPod touch
    how a bout ipod: itype
    ipod:/User/Documents root# ln -s / home
    then " ln:creating symbolic link 'home/' : is a directory " show up

Share This Page