Getting 2.0 or not

Discussion in 'iPod touch Firmware 2.X' started by mstrmnky, Sep 28, 2008.

  1. mstrmnky

    mstrmnky New Member

    Joined:
    May 13, 2008
    Messages:
    17
    Likes Received:
    0
    ok i really want to get the 2.0 upgrade but i am scared bcuz everyone keeps saying i have to resote my ipod, but i have all my apps on it and i will lose everything. so if i upgrade it to 2.0 can i still jailbreak it?? and is it worth it, because i am looking forward to using winterboard. thanks
  2. Baker5

    Baker5 Well-Known Member

    Joined:
    Jun 26, 2008
    Messages:
    3,230
    Likes Received:
    40
    Device:
    iPhone 5 (White)
    yes you can jailbreak it but why not just go all the way to 2.1 and stay clean and not jailbreak
    its worth it in the end
  3. TmacHot

    TmacHot Active Member

    Joined:
    Apr 24, 2008
    Messages:
    1,723
    Likes Received:
    0
    Device:
    iPod touch
    jailbreak is fine
    if you want to jailbreak your ipod jailbreak it to 2.0
    2.1 is unstabble for the moments
  4. fear_2670

    fear_2670 Banned

    Joined:
    Aug 17, 2008
    Messages:
    3,626
    Likes Received:
    0
    Warning

    Jailbreak = 2.0,2.0.1,2.0.2.
    If you upgrade 2.1(needs iTunes 8.0) then you can't jailbreak, yet.
    My opinion, go for 2.1 and don't jailbreak, it's better and safer.
  5. Baker5

    Baker5 Well-Known Member

    Joined:
    Jun 26, 2008
    Messages:
    3,230
    Likes Received:
    40
    Device:
    iPhone 5 (White)
    yes yet is the keyword in that sentence because it probably wont happen
  6. Gitykins

    Gitykins Banned

    Joined:
    May 16, 2008
    Messages:
    3,760
    Likes Received:
    1
    Wait WTF?

    Jailbroken 2.1 is definitely the BEST firmware+jailbreak combination. Why would get halfway but not make it epic?

    And 2.1 has been jailbroken for like 2 weeks.


    And, all future firmwares will be easily jailbreakable; Dev team found a permanent hardware exploit that can always be used for uploading a ramdisk.
  7. jfb392

    jfb392 New Member

    Joined:
    Oct 20, 2007
    Messages:
    2,512
    Likes Received:
    21
    Device:
    iPod touch
    The ramdisk isn't even part of Pwnage, but you are correct that it is a hardware exploit.
    The exploit itself relies on a bug in DFU's certificate checking; pass a malformed certificate and overflow the check, then use that overflow to execute unsigned code or strap a patched image (it straps a patched WTF 0x1227).

    OP: None of your 1.x applications work on 2.x, so it doesn't matter if you lose them.
    Upgrade to 2.1 and use QuickPwn or restore directly to a pwned 2.1 .ipsw created by PwnageTool or XPwn.

Share This Page