GenPass Compiling Error

Discussion in 'iPod touch' started by personman, Apr 5, 2010.

  1. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    Code:
    Justin-Cliffords-MacBook-Pro:Downloads Justin$ gcc genpass.c openssl/libcrypto.a -o genpass -I openssl/include/
    genpass.c: In function ‘hash_platform’:
    genpass.c:30: warning: pointer targets in passing argument 1 of ‘SHA1’ differ in signedness
    genpass.c: In function ‘main’:
    genpass.c:74: warning: integer constant is too large for ‘long’ type
    genpass.c:75: warning: integer constant is too large for ‘long’ type
    genpass.c:76: warning: integer constant is too large for ‘long’ type
    genpass.c:77: warning: integer constant is too large for ‘long’ type
    genpass.c:101: warning: passing argument 4 of ‘qsort’ from incompatible pointer type
    This is what I get when I try to compile GenPass. I tried using the version from TheiPhoneWiki and from the Chronic Dev Google Code Page and both get the same error. Anybody know why and how I can fix it because it does compile but gives me incorrect keys. Could this be due to the fact I'm running a Hackintosh on 10.5.2?
    ------------------double post merged------------------
    My friend got this answer on Yahoo answers. Does anyone know what this means and how to fix it?

Share This Page