FW 1.1.4 Rant

Discussion in 'iOS Jailbreak & Cydia' started by 123qwesz, Aug 22, 2008.

  1. 123qwesz

    123qwesz Member

    Joined:
    Dec 7, 2007
    Messages:
    238
    Likes Received:
    2
    Device:
    iPhone 3G (White)
    Don't get me wrong, Firmware 1.1.4 supports most applications that were created by some of us users and I appreciate all the hard work they have done.

    Now with the new firmware 2.0 and up 2.0.2, I have come to realize that most of this new, exciting and fun games are not applicable with us previous users of the iphone/ipod touch.
    Such examples would include that of the hotmail application incorporated into the mail.app, along with the updated 2.0.5 of the gpsPhone, you get the idea.

    Thus as a result, there is the great temptation to upgrade to 2.0.2. The price isn't the issue, but the applications supported does. Most of the 1.1.X firmware applications are not supported on the newer firmware.

    Are any 1.1.X firmware users sharing my dilemma?

    Please Register or Log in to view images

  2. Mortel

    Mortel Active Member

    Joined:
    Dec 6, 2007
    Messages:
    1,272
    Likes Received:
    13
    Device:
    3G iPod touch
    I would just upgrade. It's better, and more development is happening for the newer firmwares.
    It's not even that hard to get the firmware without paying for it.
  3. b1j4nt

    b1j4nt New Member

    Joined:
    Jul 29, 2008
    Messages:
    636
    Likes Received:
    0
    Device:
    iPod touch
    I got my ipod touch about a month ago and was on firmware 1.1.4, the next day i jailbroke and left it that way for maybe a week and 1/2 and it was good, i mean the old installer was great (new one not so great..) but after my 1.1.4 jailbroken got messed up because it thought all of my files were "other" files and my music and videos and everything got wiped i restored and then upgraded to 2.0 and then upgraded to 2.0.1 a week later and jailbroke, and i am there no and im quite happy. Just waiting for some new and exciting apps from the community and the store.

    Honestly i don't understand why 2.0 isn't free. Imagine all the people who buy ipod touches and are stuck on 1.1.4 not knowing there is 2.0 and stuff or not thinking its worth it. Seriously apple throw us a bone. Why would someone pay to upgrade firmware just so they can pay more money to download apps.

    Its still worth $10 though


    But anyways i did have your dilemma because I thought i was being left behind in the ipod touch community because i was on 1.1.4 while everyone was talking about new apps, app store, cydia, and stuff like that

    Please Register or Log in to view images

Share This Page