FontSwap ANNOYING BUG!?

Discussion in 'iPod touch' started by Spec-Oooop, Jul 19, 2009.

  1. Spec-Oooop

    Spec-Oooop New Member

    Joined:
    Jul 23, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    Good evening...
    today I tried out my new theme "black orange" (selfmade) and some selfmade fonts in FontSwap. But then there was a bug in the musicplayer, the statusbar clock and on the badges (pictures)...
    My theme doesn't have problemes with the Info.plist file or something like that...

    I have the bug also with the FontSwap-Starter Pack ("Neo Sans") ... an also if i put the fonts manually in /System/Library/Fonts/Cache

    ...but everything works with the default fonts

    Please Register or Log in to view images

    !?
    does anyone have a solution?

    Thanks a lot

    Please Register or Log in to view images

    Attached Files:

  2. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    I don't see any bugs... FontSwap changes the font for everything.
  3. Spec-Oooop

    Spec-Oooop New Member

    Joined:
    Jul 23, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    ?? the clock on the top is very high and the space between the 3 lines int the track-album-artist bar is very big -.-
  4. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    That's most likely the font.
  5. Spec-Oooop

    Spec-Oooop New Member

    Joined:
    Jul 23, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    I don't think so -.-
    cause when I use the default font it's the same "bug"
    ONLY when it hit RESTORE ALL FONTS TO SYSTEM FONTS its "normal" again
  6. ZMOBtiger

    ZMOBtiger New Member

    Joined:
    Mar 5, 2008
    Messages:
    731
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    I'm pretty sure that the problem is in the fonts. There is just some spacing issue. The statusbar time and badge notifications can be moved down with some plist editing:


    <key>BadgeStyle</key>
    <string>margin-top: 2px; </string>
    <key>TimeStyle</key>
    <string>margin-top: 2px; </string>

    Play around with the numbers until they look right. You will just have to deal with the other things or edit the fonts.
  7. Spec-Oooop

    Spec-Oooop New Member

    Joined:
    Jul 23, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    thanks

    Please Register or Log in to view images


    I think that the failure is in the FontSwap.app cause on my firmware 2.2.1 it worked perfectly with the starter-pack fonts like "neo Sans" or "ubunu titling" etc., too
    and now the starter-pack fonts also don't work anymore -.-
    do you wanna try it with MY font and give me feedback? the font works 100% WITHOUT swod xD

    its uploaded under this post

    Attached Files:

Share This Page