First Ipod ... First Apple ... don't disappoint me

Discussion in 'iPod touch' started by gelaro, Jun 13, 2009.

  1. gelaro

    gelaro New Member

    Joined:
    Jun 13, 2009
    Messages:
    2
    Likes Received:
    0
    I have an Ipod Touch 2nd Generation and it is my first Apple product ever. (It might be my last if this keeps up).

    My issue: Safari won't load pages. when I first got it yesterday, it loaded a couple (google and yahoo). But then it won't do anything. I type in an address and it just sits there. I pull up the favorites and touch one, and it will highlight blue but won't go to the page.

    The apps store works fine (I have downloaded a few games and a podcast), as does the youtube (I can watch clips). So the WiFi is working fine. It is just the Safari that doesn't work.

    I tried to go to the google address with the IP numbers that I saw someone else mention, and it doesn't work either.

    Any help? Thanks
  2. AllyOmega

    AllyOmega New Member

    Joined:
    Dec 19, 2008
    Messages:
    180
    Likes Received:
    0
    Device:
    2G iPod touch
    considering you got it yesterday and most likely dont have anything very important on there at this moment, i recommend restoring. just plug it in to your pc, and when it pops up in itunes, click restore. itll take a while and erase all the info on your ipod that you havent backed up, but it might help.
  3. Ihrm

    Ihrm New Member

    Joined:
    Jan 8, 2009
    Messages:
    199
    Likes Received:
    1
    Device:
    2G iPod touch
    Try to force quit the application (hold the home button until app closes). Sometimes this happens and its what I do to fix it. Also try turning off you wifi on you ipod then reconnecting. If this dosent work try re-booting.
  4. dong1225

    dong1225 Member

    Joined:
    Feb 4, 2009
    Messages:
    311
    Likes Received:
    0
    Device:
    4G iPod touch
    I can suggest few things for you to try. It seems like you just bought it and haven't loaded your iPod with two much stuff so just try restoring and don't use backup to recover your iPod. If that doesn't work than try resetting your router. I have once had an issue with my router where same thing happened except that my problem was YouTube. For some weird reason, whether it be ip or MAC, my router was limmiting traffic on certain services(probably mobile youtube's ip) I tried to solve the problem manually but was little bit too frustrated and just pressed the reset button and it worked.

    Oh and before you try any of the mehtod I mentioned, if you can, try acceding web page from other wifi hotspot. My friend was complaining about cydia being broken and not being able to connect to server but when she tried at my house, it worked seamlessly. It was other hardware's fault not iPod.

    I hope you get your iPod to work and possibly fall in love with it.

    Have a nice day!
  5. Bubalooshi

    Bubalooshi Active Member

    Joined:
    May 22, 2008
    Messages:
    2,432
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Restore your iPod. There may be an issue with something (obviously is).

    Quick Tip: Pretty much ANYTHING can be solved by a Restore except physical damage.

    The iPod Touch is an awesome device, don't let this scare you away from Apple.
  6. eladc

    eladc New Member

    Joined:
    Feb 7, 2009
    Messages:
    593
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Did you try to reboot it? >.>
  7. gelaro

    gelaro New Member

    Joined:
    Jun 13, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks all.

    I did the hard shut down by holding the home key and it started working (cuz that seemed the easiest). Perhaps that was the problem.
  8. touch_iPod

    touch_iPod Well-Known Member

    Joined:
    Mar 11, 2009
    Messages:
    3,023
    Likes Received:
    144
    Device:
    iPhone 5 (White)
    Well, what u did was a reset... If that solves ur problem, then it's good news... However, if the Safari issue still persists later, I suggest u do a REstore (like what the other forumers mentioned also) instead...

Share This Page