first gen ipod...on 2.1 JB ...shd i upgrade to 3.0?

Discussion in 'iPod touch' started by swamanator, Jul 2, 2009.

  1. swamanator

    swamanator Member

    Joined:
    Oct 16, 2007
    Messages:
    79
    Likes Received:
    0
    Device:
    iPhone 4 (White)
    im on 2.1 JP first gen ipod....shd i upgrade to 3.0 and jailbreak...or wait for like 3.1 or something??


    thanks
  2. deleted account 92

    deleted account 92 Active Member

    Joined:
    Jan 1, 2008
    Messages:
    2,797
    Likes Received:
    20
    I would at least upgrade to 3.0 and jailbreak. That's what I did.
  3. huggins0484

    huggins0484 New Member

    Joined:
    Oct 12, 2007
    Messages:
    124
    Likes Received:
    0
    i was in the same position you were.. and i upgraded to 3.0 and jailbroke it.
    its pretty nice

    Please Register or Log in to view images

  4. swamanator

    swamanator Member

    Joined:
    Oct 16, 2007
    Messages:
    79
    Likes Received:
    0
    Device:
    iPhone 4 (White)
    im just like...if i upgrade now...and 3.1 or something comes out...then yea...i would have to do it all over again...with my apps and stuff....

    are all apps compatible yet with 3.0?
  5. deleted account 92

    deleted account 92 Active Member

    Joined:
    Jan 1, 2008
    Messages:
    2,797
    Likes Received:
    20
    No, not all the Cydia apps are.
  6. The Untouchable iPod

    The Untouchable iPod Member

    Joined:
    Apr 15, 2008
    Messages:
    118
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    there is a lot of bugs in 3.0 but i would say go ahead and upgrade

Share This Page