Firmware?

Discussion in 'iPod touch' started by smoothfreeze, Dec 29, 2008.

  1. smoothfreeze

    smoothfreeze Member

    Joined:
    Dec 29, 2008
    Messages:
    155
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Should I upgrade my firmware to the latest one? Because I want to install Palringo Instant Messenger (requires 2.2) on my iPod touch (2.1). I feel like sticking to my 2.1 in case there is jailbreak for the iPod touch 2G (in the FUTURE of course).

    Advice please.
  2. Armageda

    Armageda New Member

    Joined:
    Dec 3, 2008
    Messages:
    100
    Likes Received:
    0
    When there will be a jailbreak, it will be for Firmware 2.2, you can be sure of that.

    Also, you can always go back to Firmware 2.1.1 with iRecovery
  3. smoothfreeze

    smoothfreeze Member

    Joined:
    Dec 29, 2008
    Messages:
    155
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    iRecovery? Never heard of that before. Thanks, i'll upgrade right now.

Share This Page