Firmware or Wi-Fi issue?

Discussion in 'iPod touch Firmware 2.X' started by ThePickler, Nov 24, 2008.

  1. ThePickler

    ThePickler Member

    Joined:
    Sep 20, 2008
    Messages:
    243
    Likes Received:
    4
    Device:
    iPhone 5S
    I updated the firmware this at my house this Friday. However when I visited my parent's house for the Thanksgiving holiday I can no longer connect properly to their Wi-Fi network. My iPod Touch had worked on their network before the firmware update.

    My iPod can see the network and seems to connect to it but does not show the Wi-Fi icon and cannot navigate any webpages.

    I have also tried going into the connection settings and manually by entering into the iPod the IP address and subnet mask etc. experimenting with omitting and including the fields. The iPod shows the correct DHCP settings.

    It is a Static IP network with DHCP.

    When I enter the addresses manually the iPod does show the Wi-Fi icon but still cannot navigate webpages.

    All of the other laptops and Desktop PCs both on the Wi-Fi and LAN work perfectly fine. I've also tried power cycling the iPod and renewing the connection.

    I'm desperate for new ideas.
    ------------------double post merged------------------
    I think its fixed now, but I still don't understand why.

    I found the "Forget this Network" option at the top of the network configuration. After using it it looks like I have my Internet back, yay!

Share This Page