Few questions before Jailbreaking

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by Salamantis, Aug 20, 2008.

  1. Salamantis

    Salamantis New Member

    Joined:
    May 21, 2008
    Messages:
    255
    Likes Received:
    0
    Device:
    2G iPod touch
    Hello,

    Sorry if these have been covered before, but I couldn't find them anywhere.

    • Can I upgrade from 1.1.4 to 2.0.1 (or 2.0.2) without losing my apps and themes?
    • If I find iPod1,1_2.0.1_5B108_Restore.ipsw, that means I can get the 2.0 update without paying, right?

    Thanks!
  2. Baker5

    Baker5 Well-Known Member

    Joined:
    Jun 26, 2008
    Messages:
    3,230
    Likes Received:
    40
    Device:
    iPhone 5 (White)
    1 idk
    2 i beleive so
  3. specialsyco

    specialsyco New Member

    Joined:
    Jan 20, 2008
    Messages:
    673
    Likes Received:
    0
    1 no you have to restore which replaces all of your file but you can ssh into you ipod and copy them and then use them with winterboard on 2.0, assuming they're summerboard themes
    2.yes you would have to pwn that firmware
  4. Baker5

    Baker5 Well-Known Member

    Joined:
    Jun 26, 2008
    Messages:
    3,230
    Likes Received:
    40
    Device:
    iPhone 5 (White)
    see what i mean these guys are so fast but i got the second one right and thats what counts
  5. Gitykins

    Gitykins Banned

    Joined:
    May 16, 2008
    Messages:
    3,760
    Likes Received:
    1
    More in-depth:

    1) Your applications will not work on the completely rewritten 2.0 firmware. If you're lucky, some or most of the apps you used in 1.1.x will be in 2.0.x Cydia. You can backup your /var/mobile/Library/SummerBoard folder and put it back in at the same directory for use with WinterBoard on 2.0.x (WinterBoard = SummerBoard replacement)

    2) Yes, you will get 2.0.1 (that firmware that you DL'ed) and all future 2.x updates for free.
  6. Salamantis

    Salamantis New Member

    Joined:
    May 21, 2008
    Messages:
    255
    Likes Received:
    0
    Device:
    2G iPod touch
    Thanks for the replies! This board is really helpful

    Please Register or Log in to view images



    One question tho, when I use PwnageTool, do I need to download 2.0, then update to 2.0.2 using iTunes, or can I just download 2.0.2 and restore to that directly?
  7. Gitykins

    Gitykins Banned

    Joined:
    May 16, 2008
    Messages:
    3,760
    Likes Received:
    1
    You can just go directly to 2.0.2

    You cannot use PwnageTool 2.0.2 for 2.0.2 firmware (deceiving, I know). You need to use QuickPwn on Windows to jailbreak 2.0.2.

    You can use PwnageTool for Mac 2.0.2 to jailbreak either 2.0.1 or 2.0 firmwares, but you need Windows to jailbreak 2.0.2 as of now until it's ported.
  8. Salamantis

    Salamantis New Member

    Joined:
    May 21, 2008
    Messages:
    255
    Likes Received:
    0
    Device:
    2G iPod touch
    Thanks for the fast reply, so if I understand this correctly I must:
    Download iPod1,1_2.0.2_5C1_Restore.ipsw,
    In iTunes on my Mac restore to that firmware,
    Launch QuickPwn in my virtual machine and pwn it using the same firmware I downloaded before?

    Seems simple enough, I just hope that I can pwn a Mac-formatted iPod Touch in Windows.
  9. Gitykins

    Gitykins Banned

    Joined:
    May 16, 2008
    Messages:
    3,760
    Likes Received:
    1
    QuickPwn does not create/restore to a custom firmware. It jailbreak the iPod without changing the firmware and just editing files. Yes, I'm fairly sure using a windows emulator would work.
  10. Salamantis

    Salamantis New Member

    Joined:
    May 21, 2008
    Messages:
    255
    Likes Received:
    0
    Device:
    2G iPod touch
    Once again, thanks. But I have another question, and I promise, last one for now

    Please Register or Log in to view images



    Since QuickPwn edits files and does not restore, I figure you need to have the same firmware on your iPod as you select in QuickPwn. Since I'm on 1.1.4, iTunes won't let me update without paying 10$ for 2.0, how do I bypass this to restore to 2.0.2?

    Thanks!

Share This Page