Error help

Discussion in 'iPod touch 1.1.x Jailbreak' started by knight24b, Dec 2, 2007.

  1. knight24b

    knight24b New Member

    Joined:
    Nov 27, 2007
    Messages:
    2
    Likes Received:
    0
    Firmware 1.0x is required for this version of Sumerboard!...

    please help what does this mean??

    thanks

Share This Page