iOS 4.0 Error after Mobile Substrate Update

Discussion in 'iOS Jailbreak & Cydia' started by Baby_Bella, Jun 22, 2010.

  1. Baby_Bella

    Baby_Bella New Member

    Joined:
    Jul 28, 2009
    Messages:
    198
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    I keep getting this error message since I updated MobileSubstrate. Every time I unlock my phone this message appears and it keeps coming up. I updated sbsettings too and when I go to swipe the status bar to open sbsettings, i get the same error message... Can anyone help? I'm using a IPhone 3g on ios 4.0 final fw

    Attached Files:

  2. Appman

    Appman Community Development Staff Member

    Joined:
    Jul 9, 2009
    Messages:
    4,034
    Likes Received:
    56
    Device:
    4G iPod touch
    Did you try restarting?
  3. DarkAura17

    DarkAura17 Well-Known Member

    Joined:
    Mar 15, 2009
    Messages:
    2,467
    Likes Received:
    77
    Device:
    iPhone 5S
    got this too. It's the infinite boot loop. I am in the process of rejailbreaking my ipod. I suggest the same for you, it won't go away, I've tried everything.
  4. jimbeam

    jimbeam Active Member

    Joined:
    Nov 19, 2007
    Messages:
    3,694
    Likes Received:
    12
    Device:
    iPhone 3G (Black)
    Your in safe mode. Probably caused by a ms extension. Try uninstalling SBsettings and what ever other extentions you have installed and reinstall them one at a time to see which one puts you in safe mode.

    I had winterboard installed when I updated and it put me in safe mode until I uninstalled it.
  5. DarkAura17

    DarkAura17 Well-Known Member

    Joined:
    Mar 15, 2009
    Messages:
    2,467
    Likes Received:
    77
    Device:
    iPhone 5S
    I've tried that to: winterboard, sbsettings, mobileterminal, but nothing worked. again i strongly suggest to restore and rejailbreak.
  6. CarlosTheJackl

    CarlosTheJackl Member

    Joined:
    Oct 11, 2009
    Messages:
    497
    Likes Received:
    14
    mobile substrate has not been fully updated for iOS 4.0
    as the dev team has said the current jailbreak is BETA. meaning do not use it unless you dare or if your a dev and you need to make sure that your apps will work in 4.0.

    Hence why winterboard, and many other apps that use mobile substrate don't work.
  7. jhloa2

    jhloa2 Member

    Joined:
    Feb 11, 2008
    Messages:
    714
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    after the mobile substrate update sbsettings works now
  8. Baby_Bella

    Baby_Bella New Member

    Joined:
    Jul 28, 2009
    Messages:
    198
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    So really what should I do... Should I just restore and rejailbreak?
  9. CarlosTheJackl

    CarlosTheJackl Member

    Joined:
    Oct 11, 2009
    Messages:
    497
    Likes Received:
    14
    no.
    wait for an official redsnow/other jailbreak, not any redsn0w beta stuff.

    Not everything has been updated so just sit tight till then.
  10. thunderstruck7

    thunderstruck7 Member

    Joined:
    Dec 28, 2008
    Messages:
    106
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Mine's doing the same thing unfortunately. A patient individual would wait for a new MobileSubstrate update but I'm going to restore and re-jailbreak again. I'll let you know if it fixes the problem.

Share This Page