Emulators on Ipod Touch

Discussion in 'iOS Emulators' started by simoneous, Aug 18, 2008.

  1. simoneous

    simoneous New Member

    Joined:
    Aug 18, 2008
    Messages:
    36
    Likes Received:
    0
    Hi

    I have just bought a brand new ipod touch with the latest firware on it (2.00.1 (i think...)). Anyway, Partly why I bought one was because I saw you could play emulators of SNES, GBA and PSX.

    So the question is: What is the best way to acheive this?

    Now I am quite computer literate so I am not a n00b in that regard. And also, my iPoT is not jailbroken...so I would like a comprehensive guide on how to do that

    Please Register or Log in to view images



    I also have lots of ROMS on my computer which I would like to put on! GBA and SNES ones.

    And would I need to downgrade firmware?? Or just wait??

    Anyways, thanks in advance for all the help; and I do know this is a jumbo question but all help would be greatly appreciated (website links as well!!!)
  2. simoneous

    simoneous New Member

    Joined:
    Aug 18, 2008
    Messages:
    36
    Likes Received:
    0
  3. djroebuck

    djroebuck New Member

    Joined:
    Dec 26, 2007
    Messages:
    35
    Likes Received:
    1
    Device:
    iPod touch
    *cough* search *cough*
  4. simoneous

    simoneous New Member

    Joined:
    Aug 18, 2008
    Messages:
    36
    Likes Received:
    0
    *cough* best way to acheive this!!?; what is the best jailbreak; what firmware is best to downgrade to?*cough*

    But I appreciate the reply; and search I will!
  5. BroadStBullies

    BroadStBullies Well-Known Member

    Joined:
    Dec 15, 2007
    Messages:
    2,007
    Likes Received:
    26
    Device:
    2G iPod touch
    On 2.0 there is only GBA Turbo Grafix 16 and NES. To get GENESIS, GBC, GBA, Turbo Grafix 16, SNES, PSX, and NES you have to be on 1.1.4 or wait til Zodttd ports the emulators to 2.0
  6. spoonforknife

    spoonforknife Retired Moderator

    Joined:
    Nov 15, 2007
    Messages:
    6,896
    Likes Received:
    317
    Hey dude! If you have Cydia, one of the sources will be from zodttd.com. You will have the package quake4iphone on it, a great Quake emulator! NES will also be in Cydia. But if you want some of zodttd's new beta stuff, you can make a video of you playing quake4iphone and send it to him on http://zodttd.com, his forum/website. Create an account, and he will give you a private beta tester account to use with beta applications like gpSPhone (GameBoy Advance), Temper4iPhone (TurboGrafx), and more that are coming soon.

    Enjoy!
  7. beeshabo

    beeshabo Active Member

    Joined:
    Aug 4, 2008
    Messages:
    842
    Likes Received:
    27
    Device:
    iPhone 4S (White)
    spoon, your post helped me too!! thanks
  8. simoneous

    simoneous New Member

    Joined:
    Aug 18, 2008
    Messages:
    36
    Likes Received:
    0
    Okay, thanks. So what is the difference between Cydia and Installer?? and can you have both?
  9. Tyr0

    Tyr0 New Member

    Joined:
    Dec 17, 2007
    Messages:
    533
    Likes Received:
    6
    Device:
    iPhone 3GS (White)
    you can if you want to, but cydia is more advanced, while installer is for "noobs" and the average user. But it wouldnt hurt to have both, i do.
  10. simoneous

    simoneous New Member

    Joined:
    Aug 18, 2008
    Messages:
    36
    Likes Received:
    0
    now; this may seem like a nooby question but how do you install both??

Share This Page