Download Newest gpsPhone Version 1.2.0

Discussion in 'Gameboy Advance emulator (gpSPhone)' started by goodolw, Jan 7, 2008.

Thread Status:
Not open for further replies.
  1. goodolw

    goodolw New Member

    Joined:
    Dec 13, 2007
    Messages:
    23
    Likes Received:
    0
    Just in case it was not in installer

    Changes 1.2.0:
    - Added initial support for .zip archived .gba files. The .zip must ONLY contain a single .gba file.
    - Added support for volume changing via iPhone and iTouch volume controls.
    - Added option to add a new savestate file or overwrite the previously loaded one.
    - Improved save state support. No more crashes and save states are timestamped. Compatibility remains for old version savestates.
    - Improved suspending/resuming of the emulator.
    - Improved button input routine. Now combo buttons work better.
    - Improved the default skin/overlay to support better left and right button input.
    - Fixed a bug causing the emulator to crash when headphone jacks were inserted or removed during gameplay.
    - Fixed a delete ROMs bug.
    - Fixed a bug in the controller skins that made L+R goto the menu screen.
    - Moved the unscaled GBA screen to the top of the actual screen.
    - Increased performance.

    http://zodttd.com/forum/index.php?topic=435.0

    Installation:
    YOU MUST HAVE THE CORRECT gba_bios.bin FILE INSTALLED FOR THIS EMULATOR TO WORK!
    After you install gpSPhone, you MUST set the gpSPhone file's permission to 0755! Otherwise it won't run! This will be solved when it get's on an Installer.app repository.
    It requires a bit of installation.
    - Unzip the gpSPhone.app directory to /Applications
    - Change the "gpSPhone" file's permission to 0755 using a tool such as WinSCP
    - Place gba_bios.bin (GBA BIOS) in /Applications/gpSPhone.app/
    - Make sure there is the following directory on your iPhone / iTouch, if not create it: /var/root/Media/ROMs/GBA
    - Place roms anywhere on iPhone / iTouch but preferabbly in the default file selection directory: /var/root/Media/ROMs/GBA
  2. lildudejds

    lildudejds Member

    Joined:
    Oct 24, 2007
    Messages:
    153
    Likes Received:
    0
    Device:
    iPod touch
    why is it not in installer?
  3. AlexRADL

    AlexRADL Retired Moderator

    Joined:
    Oct 9, 2007
    Messages:
    3,816
    Likes Received:
    65
    It is in installer, check again, refresh your sources.
  4. goodolw

    goodolw New Member

    Joined:
    Dec 13, 2007
    Messages:
    23
    Likes Received:
    0
    what's the other source? I had to add the zodttd source for a update. And they just made one recently
  5. [AFX]

    [AFX] Well-Known Member

    Joined:
    Nov 4, 2007
    Messages:
    1,246
    Likes Received:
    134
  6. Flagpole

    Flagpole Member

    Joined:
    Nov 12, 2007
    Messages:
    592
    Likes Received:
    12
    Device:
    iPhone 4 (Black)
    so i just installed this and it keeps telling me to upgrade. it says in the upgrade menue to upgrade it to a lower version 3 times. then when i do that ittells me to upgrade to this. is there any way to manualy install it so that it doesnt tell me to upgrade?
  7. mombopete

    mombopete Member

    Joined:
    Oct 19, 2007
    Messages:
    483
    Likes Received:
    2
    Same thing with me. This is really irritating. I just removed the repo so I did not get this message anymore. I am using the older version. Please help.
  8. AlexRADL

    AlexRADL Retired Moderator

    Joined:
    Oct 9, 2007
    Messages:
    3,816
    Likes Received:
    65
    Since there is already a thread about this topic, this thread is now closed. See link provided by AFX.
Thread Status:
Not open for further replies.

Share This Page