Downgrading from 2.2.1 to 2.1?

Discussion in 'iPod touch Firmware 2.X' started by baysic, Mar 5, 2009.

  1. baysic

    baysic New Member

    Joined:
    Jan 16, 2008
    Messages:
    12
    Likes Received:
    0
    Is this possible to do this directly? or would i need to downgrade to 1.1.5 first or something?

    and at this point, which firmware is better after jailbreaking? like is it true that a lot of apps dont work for 2.2.1?
  2. rb26dett

    rb26dett New Member

    Joined:
    Jul 18, 2008
    Messages:
    269
    Likes Received:
    0
    Device:
    iPod touch
    the 2.2.1 jb works fine just use quikpwn
  3. Dani3l.Damon

    Dani3l.Damon New Member

    Joined:
    Mar 30, 2009
    Messages:
    22
    Likes Received:
    0
    depending on your gen 1st or 2nd.. 1st gen use quickpwn 2nd gen use quickfreedom.. worked for me
  4. bigcj55

    bigcj55 Banned

    Joined:
    Jan 2, 2009
    Messages:
    582
    Likes Received:
    1
    Device:
    iPhone 3G (Black)
    Everything works for me....Always has since tethered...

    Please Register or Log in to view images

Share This Page